mail-client/claws-mail: Bump to version 3.17.0
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 17 Aug 2018 09:21:10 +0000 (11:21 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 17 Aug 2018 09:54:50 +0000 (11:54 +0200)
Package-Manager: Portage-2.3.46, Repoman-2.3.10

mail-client/claws-mail/Manifest
mail-client/claws-mail/claws-mail-3.17.0.ebuild [new file with mode: 0644]
mail-client/claws-mail/metadata.xml

index bb4d136a8ec24ed7640b30176cbd07b31e03d77b..4976d2a2201cf874dde61dd00b816f37ffab9212 100644 (file)
@@ -1,3 +1,4 @@
 DIST claws-mail-3.15.0.tar.xz 5665648 BLAKE2B f25356372b65f2df072eb2774fca87514c2da59811e78650e26ae58c1b518e229cba62cf1b0d0ad72107e292c9d87450f7d2508c02f34c5c9c70d944f9866823 SHA512 667cb0ea2f7c5d8e8b6046313ed7698c378f504caeeaa54348ba228317538dfc040e4ddf80f4aaa1491858a7803954e89599b1e479febe7cf1ab4bae5a638dc8
 DIST claws-mail-3.15.1.tar.xz 5665468 BLAKE2B c6d4c5875f82f836815193b330427bdd533be5445706fc437b1c30be8e52325a2b824e8a1d1332bb286ac9ea2bd4b872943709d9ff78b20a6a3ff5b781808d25 SHA512 11113ab2bc75571b9a71b11ee3f7fe4773ff7b17132f29e6637aa7b7b9a7f8ed125430ee7e5ab5c9842463d776a96be150d7c8e1e3d682b955dd582a6a6ce68c
 DIST claws-mail-3.16.0.tar.xz 5913948 BLAKE2B 6744045de6bc3945221569a9ae1cdcd849ec11c4f5dbfe966ca70c7c2ab3f5d9ded1dbd5bcedffdc756809c1802d31d955b5c6c53f20a00be5abc861db340d0f SHA512 5c96e21b4c5117b67ccfe4178c68e2f1b1449f882d6ecf22041e41f08fd607c6ce7afe6c7fdbd039da7ffc5673d366551b15d3e4b7de8d758fc1554a8eadc55e
+DIST claws-mail-3.17.0.tar.xz 4752924 BLAKE2B 3636fc44548220f6358204a01976bc0502e65a7734c8b1e6720275ce148b60a1c291b17a0055190a9d0e99407fc20615b05c0c4d752a6eecb5d276a764c4611b SHA512 e4eea0479425dd22dcda5f73c69336f309f5cb7c652a4cd11365bdca4efe9739c46e4d51e973dcca346a20fe25af4506584abf4d2e769e60abd020c73e844bdc
diff --git a/mail-client/claws-mail/claws-mail-3.17.0.ebuild b/mail-client/claws-mail/claws-mail-3.17.0.ebuild
new file mode 100644 (file)
index 0000000..c9a2357
--- /dev/null
@@ -0,0 +1,213 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="https://www.claws-mail.org/"
+
+if [[ "${PV}" == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="git://git.claws-mail.org/claws.git"
+else
+       SRC_URI="https://www.claws-mail.org/download.php?file=releases/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls gtk3 +imap ipv6 ldap +libcanberra +libindicate +libnotify networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+REQUIRED_USE="libcanberra? ( notification )
+       libindicate? ( notification )
+       libnotify? ( notification )
+       networkmanager? ( dbus )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       smime? ( pgp )"
+
+COMMONDEPEND="
+       dev-libs/nettle
+       net-mail/ytnef
+       archive? (
+               app-arch/libarchive
+               >=net-misc/curl-7.9.7
+       )
+       bogofilter? ( mail-filter/bogofilter )
+       calendar? (
+               >=dev-libs/libical-2.0.0:=
+               >=net-misc/curl-7.9.7
+       )
+       dbus? ( >=dev-libs/dbus-glib-0.60 )
+       gdata? ( >=dev-libs/libgdata-0.17.2 )
+       dillo? ( www-client/dillo )
+       gnutls? ( >=net-libs/gnutls-3.0 )
+       gtk3? ( x11-libs/gtk+:3 )
+       !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+       imap? ( >=net-libs/libetpan-0.57 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       nls? ( >=sys-devel/gettext-0.18 )
+       nntp? ( >=net-libs/libetpan-0.57 )
+       notification? (
+               dev-libs/glib:2
+               libcanberra? (  media-libs/libcanberra[gtk] )
+               libindicate? ( dev-libs/libindicate:3[gtk] )
+               libnotify? ( x11-libs/libnotify )
+       )
+       pda? ( >=app-pda/jpilot-0.99 )
+       pdf? ( app-text/poppler[cairo] )
+       pgp? ( >=app-crypt/gpgme-1.0.0 )
+       session? (
+               x11-libs/libICE
+               x11-libs/libSM
+       )
+       smime? ( >=app-crypt/gpgme-1.0.0 )
+       spam-report? ( >=net-misc/curl-7.9.7 )
+       spell? ( >=app-text/enchant-1.0.0 )
+       startup-notification? ( x11-libs/startup-notification )
+       svg? ( >=gnome-base/librsvg-2.40.5 )
+       valgrind? ( dev-util/valgrind )
+"
+
+DEPEND="${COMMONDEPEND}
+       app-arch/xz-utils
+       virtual/pkgconfig
+       xface? ( >=media-libs/compface-1.4 )"
+
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       x11-misc/shared-mime-info
+       clamav? ( app-antivirus/clamav )
+       networkmanager? ( net-misc/networkmanager )
+       pdf? ( app-text/ghostscript-gpl )
+       perl? ( dev-lang/perl:= )
+       python? (
+               ${PYTHON_DEPS}
+               >=dev-python/pygtk-2.10.3
+       )
+       rss? (
+               dev-libs/libxml2
+               net-misc/curl
+       )"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       # Don't use libsoup-gnome (bug #565924)
+       export HAVE_LIBSOUP_GNOME=no
+
+       local myeconfargs=(
+               --disable-bsfilter-plugin
+               --disable-fancy-plugin
+               --disable-generic-umpc
+               --enable-acpi_notifier-plugin
+               --enable-address_keeper-plugin
+               --enable-alternate-addressbook
+               --enable-att_remover-plugin
+               --enable-attachwarner-plugin
+               --enable-fetchinfo-plugin
+               --enable-mailmbox-plugin
+               --enable-newmail-plugin
+               --enable-tnef_parse-plugin
+               --with-password-encryption=$(usex gnutls gnutls old)
+               $(use_enable archive archive-plugin)
+               $(use_enable bogofilter bogofilter-plugin)
+               $(use_enable calendar vcalendar-plugin)
+               $(use_enable clamav clamd-plugin)
+               $(use_enable dbus)
+               $(use_enable debug crash-dialog)
+               $(use_enable dillo dillo-plugin)
+               $(use_enable doc manual)
+               $(use_enable gdata gdata-plugin)
+               $(use_enable gnutls)
+               $(use_enable gtk3)
+               $(use_enable ipv6)
+               $(use_enable ldap)
+               $(use_enable networkmanager)
+               $(use_enable nls)
+               $(use_enable notification notification-plugin)
+               $(use_enable pda jpilot)
+               $(use_enable pdf pdf_viewer-plugin)
+               $(use_enable perl perl-plugin)
+               $(use_enable pgp pgpcore-plugin)
+               $(use_enable pgp pgpinline-plugin)
+               $(use_enable pgp pgpmime-plugin)
+               $(use_enable python python-plugin)
+               $(use_enable rss rssyl-plugin)
+               $(use_enable session libsm)
+               $(use_enable sieve managesieve-plugin)
+               $(use_enable smime smime-plugin)
+               $(use_enable spam-report spam_report-plugin)
+               $(use_enable spamassassin spamassassin-plugin)
+               $(use_enable spell enchant)
+               $(use_enable startup-notification)
+               $(use_enable svg)
+               $(use_enable valgrind valgrind)
+               $(use_enable xface compface)
+       )
+
+       # libetpan is needed if user wants nntp or imap functionality
+       if use imap || use nntp ; then
+               myeconfargs+=( --enable-libetpan )
+       else
+               myeconfargs+=( --disable-libetpan )
+       fi
+
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+       default
+
+       # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins ${PN}.png
+       local size
+       for size in 64 128 ; do
+               newicon -s ${size} ${PN}-${size}x${size}.png ${PN}.png
+       done
+
+       docinto tools
+       dodoc tools/README*
+
+       domenu ${PN}.desktop
+
+       einfo "Installing extra tools"
+       cd "${S}"/tools || die
+       exeinto /usr/$(get_libdir)/${PN}/tools
+       doexe *.pl *.py *.conf *.sh
+       doexe tb2claws-mail update-po uudec uuooffice
+
+       # kill useless files
+       rm -f "${ED%/}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+       ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+       ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+       ewarn "- The gtkhtml2 and trayicon plugins have been dropped entirely"
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}
index 2cddcb6d4d5223efd545653244e97ef4e0f7b903..9766136e35a2edf77a33a704f5cc32ca261b3f3c 100644 (file)
@@ -11,6 +11,7 @@
        </maintainer>
        <use>
                <flag name="archive">Enable archiving plugin</flag>
+               <flag name="dillo">Enable dillo html viewer plugin</flag>
                <flag name="gdata">Enable plugin for access to Google
                data providers</flag>
                <flag name="gtk3">Build support for GTK+3</flag>