stop using $IMAGE
authorMike Frysinger <vapier@gentoo.org>
Sat, 10 Mar 2007 14:24:28 +0000 (14:24 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 10 Mar 2007 14:24:28 +0000 (14:24 +0000)
Package-Manager: portage-2.1.2.2

media-plugins/vdr-autosort/vdr-autosort-0.0.10.ebuild
media-plugins/vdr-setup/vdr-setup-0.3.1.ebuild

index fa394482f4208b0fb6d479cb0b3f843638271f14..5f50d242b5fb51123569908eebf9ecf59c39b2dc 100644 (file)
@@ -1,22 +1,21 @@
-# Copyright 2003-2007 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-autosort/vdr-autosort-0.0.10.ebuild,v 1.2 2007/01/05 16:23:55 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-autosort/vdr-autosort-0.0.10.ebuild,v 1.3 2007/03/10 14:23:43 vapier Exp $
 
-IUSE=""
 inherit vdr-plugin eutils
 
 DESCRIPTION="VDR plugin: Auto-sort channels.conf"
 HOMEPAGE="http://www.copypointburscheid.de/linux/autosort.htm"
 SRC_URI="http://www.copypointburscheid.de/linux/${P}.tgz"
 
-KEYWORDS="~x86"
-SLOT="0"
 LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
 
 DEPEND=">=media-video/vdr-1.3.32"
 
-src_install()
-{
+src_install() {
        vdr-plugin_src_install
        insinto /etc/vdr/plugins
        doins autosort.conf
@@ -24,14 +23,13 @@ src_install()
 
 pkg_preinst() {
        if [[ ! -L ${ROOT}/etc/vdr/channels.conf ]]; then
-               cp ${ROOT}/etc/vdr/channels.conf ${IMAGE}/etc/vdr/channels.conf.autosort.bak
+               cp "${ROOT}"/etc/vdr/channels.conf "${D}"/etc/vdr/channels.conf.autosort.bak
                fowners vdr:vdr /etc/vdr/channels.conf.autosort.bak
        fi
 }
 
 
-pkg_postinst()
-{
+pkg_postinst() {
        vdr-plugin_pkg_postinst
        echo
        elog "You will find a backup of your channels.conf in /etc/vdr/channels.conf.autosort.bak"
index b785a83e2646226e61bf4320d9b99bcbf93bc478..3ecf3e1782ae38aab6b48f500070fccac1dd3271 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-setup/vdr-setup-0.3.1.ebuild,v 1.7 2007/01/05 16:47:35 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-setup/vdr-setup-0.3.1.ebuild,v 1.8 2007/03/10 14:24:28 vapier Exp $
 
 inherit vdr-plugin
 
@@ -54,11 +54,10 @@ src_install() {
 }
 
 pkg_preinst() {
-
        if [[ ! -L ${ROOT}/etc/vdr/channels.conf ]]; then
-       cp ${ROOT}/etc/vdr/channels.conf ${IMAGE}/etc/vdr/channels.d/channels.conf.bak
-       cp ${ROOT}/etc/vdr/channels.conf ${IMAGE}/etc/vdr/channels.d/channels.conf
-       fowners vdr:vdr /etc/vdr/channels.d/{channels.conf,channels.conf.bak}
+               cp "${ROOT}"/etc/vdr/channels.conf "${D}"/etc/vdr/channels.d/channels.conf.bak
+               cp "${ROOT}"/etc/vdr/channels.conf "${D}"/etc/vdr/channels.d/channels.conf
+               fowners vdr:vdr /etc/vdr/channels.d/{channels.conf,channels.conf.bak}
        fi
 }