app-emulation/fs-uae-launcher: Patch around crash under KDE Plasma
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 8 May 2019 19:55:00 +0000 (20:55 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 8 May 2019 19:57:40 +0000 (20:57 +0100)
This issue affects PyQt5 in general but I don't know the proper
solution and it's easy to patch around.

Closes: https://bugs.gentoo.org/684948
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch [new file with mode: 0644]
app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3-r1.ebuild [moved from app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild with 98% similarity]

diff --git a/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch
new file mode 100644 (file)
index 0000000..446bfd8
--- /dev/null
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/684948
+
+--- fs-uae-launcher-2.8.3/fsui/qt/qt.py        2017-01-08 19:48:56.000000000 +0000
++++ fs-uae-launcher-2.8.3/fsui/qt/qt.py        2019-05-03 22:28:16.979041988 +0100
+@@ -60,7 +60,7 @@
+     # fix_qt_for_maverick()
+     fsbc.desktop.set_open_url_in_browser_function(open_url_in_browser)
+-    qapplication = QtBaseApplication([])
++    qapplication = QtBaseApplication([''])
+     initialize_qt_style(qapplication)
+     return qapplication
similarity index 98%
rename from app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild
rename to app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3-r1.ebuild
index d782ea3d97b4cb7ceb1c68e53b8cce0274e1b82e..ea3355abae22d7651be3501a3c90fd451941c28d 100644 (file)
@@ -30,6 +30,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${P}-German-ROMs.patch
+       "${FILESDIR}"/${P}-QApplication.patch
 )
 
 src_prepare() {