net-misc/gwhois: Use Debian sources as they are still maintained
authorPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 11:06:11 +0000 (12:06 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 26 Jan 2019 11:06:23 +0000 (12:06 +0100)
Bug: https://bugs.gentoo.org/675980
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-misc/gwhois/Manifest
net-misc/gwhois/gwhois-20120626-r1.ebuild [new file with mode: 0644]

index 7d2e72b05ca98effb6be51eba1c4b03491e7e408..09ff5a1acb30095ef4acc93c6744030de71e251d 100644 (file)
@@ -1 +1,2 @@
+DIST gwhois_20120626-1.2.tar.gz 41800 BLAKE2B 695005bd37abaf0dc39593dcc3dfd01102b896dc2bb74a8f3be774d5f7316861588ca3ca621eabdeb19739abfda9be0ab215c757181d3d08ce0416f315410d0d SHA512 c18e20a033e3d2de3b1a5c81d1fdae88cfd9dbc5261b4512b87376d0909ea538db46b3380aaa426ef43904ef292662185dd2f3cb59c56dba306c41a0e827bcb0
 DIST gwhois_20120626.tar.gz 41698 BLAKE2B cce3a6eb385bb782a772a7532cecc2ae164d6ea00a42a6afa29b2ff4d16526507511c16e9cae3dab3d26e7818126b2fcd20a5d88a4affa472162f9ef30c0e464 SHA512 8ffaa611389929435f70d3f020e28249e6e3109c4e822e9318b050f52cf09d6934adbb14ab67a6361574ce8645656d5eaf24808dea453f2187352fc2b2513e0e
diff --git a/net-misc/gwhois/gwhois-20120626-r1.ebuild b/net-misc/gwhois/gwhois-20120626-r1.ebuild
new file mode 100644 (file)
index 0000000..59fb8f6
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1
+
+MY_P="${P/_p/.}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Generic whois"
+HOMEPAGE="https://julijane.de/gwhois/"
+# Debian is still maintaining it
+#SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+
+DEBIAN_VER="1.2"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${MY_P/-/_}-${DEBIAN_VER}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+       www-client/lynx
+       net-misc/curl
+       dev-lang/perl:=
+       dev-perl/libwww-perl
+       dev-perl/Net-LibIDN
+"
+DEPEND=""
+
+DOC_CONTENTS="
+       See included gwhois.xinetd for an example on how to
+       use gwhois as a whois proxy using xinetd.
+       Just copy gwhois.xinetd to /etc/xinetd.d/gwhois
+       and reload xinetd.
+"
+
+src_install() {
+       dodir /etc/gwhois
+       insinto /etc/gwhois
+       doins pattern
+       dobin gwhois
+       doman gwhois.1
+       dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       if [ -f /etc/gwhois/pattern.ripe ]; then
+               ewarn ""
+               ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+               ewarn "as it causes malfunction with this version."
+               ewarn "If you did not modify the file, just remove it."
+               ewarn ""
+               mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+       fi
+       readme.gentoo_print_elog
+}