dev-python/jinja: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Wed, 20 Nov 2019 14:21:38 +0000 (15:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:34:58 +0000 (13:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jinja/jinja-2.10.3-r1.ebuild

index 39131f10d5a93ddf4bb8c2690cff706fcdd55f1a..f021773e3385b1708c678c61de333f85e8a3d772 100644 (file)
@@ -17,20 +17,18 @@ SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc examples test"
+IUSE="examples test"
 RESTRICT="!test? ( test )"
 
 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        !dev-python/jinja:compat"
 RDEPEND="${CDEPEND}
        dev-python/markupsafe[${PYTHON_USEDEP}]"
-BDEPEND="${CDEPEND}
-       doc? (
-               dev-python/sphinx
-               dev-python/sphinx-issues
-               dev-python/pallets-sphinx-themes
-       )"
+BDEPEND="${CDEPEND}"
 
+distutils_enable_sphinx docs \
+       dev-python/sphinx-issues \
+       dev-python/pallets-sphinx-themes
 distutils_enable_tests pytest
 
 # XXX: handle Babel better?
@@ -64,12 +62,7 @@ python_compile() {
        wrap_opts distutils-r1_python_compile
 }
 
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
 python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
        if use examples ; then
                docinto examples
                dodoc -r examples/.