app-i18n/ibus-hangul: new upstream release
authorAkinori Hattori <hattya@gentoo.org>
Sat, 29 Feb 2020 02:39:56 +0000 (11:39 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 29 Feb 2020 02:39:56 +0000 (11:39 +0900)
Closes: https://github.com/gentoo/gentoo/pull/14759
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-hangul/Manifest
app-i18n/ibus-hangul/ibus-hangul-1.5.3.ebuild [new file with mode: 0644]

index 639833fb607c3ec7e1005d7ae1cd7ee3fb46ea9e..919c4733905653869ca62be69abadf88c1911860 100644 (file)
@@ -1 +1,2 @@
 DIST ibus-hangul-1.5.1.tar.gz 460517 BLAKE2B 913d0d8b8995fac3cd73ca40280761d5bf44f35134cb7e73075c233f9c1ef5aa00bb7d7b8da20a69273cd0eb8202b9deb409e1b8d1b6ebbeccccb5f0ef98d341 SHA512 1254398cc4daef2bcbb4cf5be5cfe4c3478097cc5be1f2b39861efe55529ba36602798a84c2540298c2c3b6405c1bd38c97543827c74a473dca5a2d23e3ac4ec
+DIST ibus-hangul-1.5.3.tar.gz 525834 BLAKE2B 6c92dbbde39bc42b7df974dbb23c9ef62088c8d3f63a500bd3c7e9c90b3d80d16dc1d76616620e1d7590fee549979a03585ac635761687dc11737d65fdf09e08 SHA512 ba21a8afb750e33744042c5e4f9d88891764921a37c4dbe1f4efa9883fd3c889789854af57adcd24bc1ca365ee49d2e01073c54d72cd025558b41788fb6213b4
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.3.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.3.ebuild
new file mode 100644 (file)
index 0000000..393fcb6
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Korean Hangul engine for IBus"
+HOMEPAGE="https://github.com/libhangul/ibus-hangul/wiki"
+SRC_URI="https://github.com/libhangul/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       $(python_gen_cond_dep '
+               app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       >=app-i18n/libhangul-0.1
+       nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+src_configure() {
+       econf \
+               $(use_enable nls) \
+               --with-python=${EPYTHON}
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}