app-arch/pixz: clean up style a bit
authorMike Frysinger <vapier@gentoo.org>
Thu, 16 Feb 2017 23:16:06 +0000 (18:16 -0500)
committerMike Frysinger <vapier@gentoo.org>
Thu, 16 Feb 2017 23:44:49 +0000 (18:44 -0500)
Make the ebuild look more like other ebuilds by moving the
KEYWORDS/SRC_URI settings up to the top.

app-arch/pixz/pixz-1.0.6.ebuild
app-arch/pixz/pixz-9999.ebuild

index fe9d1a813ca30a844f3065c808d3b3683eb08e1a..edba404e0d7350bd4df8fd865fd0863e04527f20 100644 (file)
@@ -1,13 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=6
+EAPI="6"
 
 inherit flag-o-matic
 
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
+       inherit git-r3 autotools
+else
+       SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
 DESCRIPTION="Parallel Indexed XZ compressor"
 HOMEPAGE="https://github.com/vasi/pixz"
+
 LICENSE="BSD-2"
 SLOT="0"
 IUSE="static"
@@ -19,15 +27,6 @@ DEPEND="${RDEPEND}
        static? ( ${LIB_DEPEND} )"
 [[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"
 
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
-       inherit git-r3 autotools
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
-       KEYWORDS="~amd64 ~arm ~x86"
-fi
-
 src_prepare() {
        default
        [[ ${PV} == "9999" ]] && eautoreconf
index fe9d1a813ca30a844f3065c808d3b3683eb08e1a..edba404e0d7350bd4df8fd865fd0863e04527f20 100644 (file)
@@ -1,13 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=6
+EAPI="6"
 
 inherit flag-o-matic
 
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
+       inherit git-r3 autotools
+else
+       SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
 DESCRIPTION="Parallel Indexed XZ compressor"
 HOMEPAGE="https://github.com/vasi/pixz"
+
 LICENSE="BSD-2"
 SLOT="0"
 IUSE="static"
@@ -19,15 +27,6 @@ DEPEND="${RDEPEND}
        static? ( ${LIB_DEPEND} )"
 [[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"
 
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
-       inherit git-r3 autotools
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
-       KEYWORDS="~amd64 ~arm ~x86"
-fi
-
 src_prepare() {
        default
        [[ ${PV} == "9999" ]] && eautoreconf