dev-python/paramiko: python3_8, use distutils_enable_sphinx
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 4 Dec 2019 01:15:01 +0000 (02:15 +0100)
committerAaron Bauman <bman@gentoo.org>
Wed, 4 Dec 2019 16:36:57 +0000 (11:36 -0500)
Tests passed.

Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/paramiko/paramiko-2.6.0.ebuild

index f10cbe2018e02dd5283f79e350c27febeb149d7d..5587e75a3c8f6e017d61e9e7e47d0e152a14aa2d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
-IUSE="doc examples server test"
+IUSE="examples server test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -28,13 +28,14 @@ RDEPEND="
 "
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
        )
 "
 
+distutils_enable_sphinx sites/docs
+
 src_prepare() {
        eapply "${FILESDIR}"/${P}-tests.patch
 
@@ -45,17 +46,11 @@ src_prepare() {
        eapply_user
 }
 
-python_compile_all() {
-       use doc && esetup.py build_sphinx -s sites/docs
-}
-
 python_test() {
        py.test -v || die "Tests fail with ${EPYTHON}"
 }
 
 python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-
        distutils-r1_python_install_all
 
        if use examples; then