virtual/libudev: Remove incorrect eudev provider from 232
authorMichał Górny <mgorny@gentoo.org>
Sat, 26 Oct 2019 15:43:59 +0000 (17:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 27 Oct 2019 15:30:40 +0000 (16:30 +0100)
Remove sys-fs/eudev from the list of providers for 232 since it does
not satisfy the requirement on that version.  Since it is the only
provider offering static-libs, remove that flag as well (reverse
dependencies have already been updated to account for that).  While
at it, bump to EAPI 7.

People who are in dire need of static libraries or eudev in general
can still install the older version of virtual/libudev.

Closes: https://bugs.gentoo.org/697550
Signed-off-by: Michał Górny <mgorny@gentoo.org>
virtual/libudev/libudev-215-r1.ebuild
virtual/libudev/libudev-232-r1.ebuild [new file with mode: 0644]
virtual/libudev/libudev-232.ebuild [deleted file]

index dac1458fb0a9da26ad158ed28e64fdc291c3aafa..8499648ba71e148adae1890dd820be59c89445e5 100644 (file)
@@ -6,7 +6,7 @@ inherit multilib-build
 
 DESCRIPTION="Virtual for libudev providers"
 SLOT="0/1"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
 IUSE="static-libs systemd"
 REQUIRED_USE="systemd? ( !static-libs )"
 
diff --git a/virtual/libudev/libudev-232-r1.ebuild b/virtual/libudev/libudev-232-r1.ebuild
new file mode 100644 (file)
index 0000000..913bd48
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-build
+
+DESCRIPTION="Virtual for libudev providers"
+SLOT="0/1"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="systemd"
+
+RDEPEND="
+       !systemd? ( >=sys-fs/udev-232:0/0[${MULTILIB_USEDEP}] )
+       systemd? ( >=sys-apps/systemd-232:0/2[${MULTILIB_USEDEP}] )
+"
diff --git a/virtual/libudev/libudev-232.ebuild b/virtual/libudev/libudev-232.ebuild
deleted file mode 100644 (file)
index 613dddc..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit multilib-build
-
-DESCRIPTION="Virtual for libudev providers"
-SLOT="0/1"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh sparc x86"
-IUSE="static-libs systemd"
-REQUIRED_USE="systemd? ( !static-libs )"
-
-RDEPEND="
-       !systemd? (
-               static-libs? (
-                       >=sys-fs/eudev-1.3:0/0[${MULTILIB_USEDEP},static-libs(-)]
-               )
-               !static-libs? ( || (
-                       >=sys-fs/eudev-1.3:0/0[${MULTILIB_USEDEP}]
-                       >=sys-fs/udev-232:0/0[${MULTILIB_USEDEP}]
-               ) )
-       )
-       systemd? ( >=sys-apps/systemd-212-r5:0/2[${MULTILIB_USEDEP}] )
-"