media-video/setpwc: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:55 +0000 (14:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:55 +0000 (14:20 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-video/setpwc/files/setpwc-1.3-fix-build-system.patch [new file with mode: 0644]
media-video/setpwc/setpwc-1.3.ebuild

diff --git a/media-video/setpwc/files/setpwc-1.3-fix-build-system.patch b/media-video/setpwc/files/setpwc-1.3-fix-build-system.patch
new file mode 100644 (file)
index 0000000..88152cf
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,18 +13,13 @@
+ # files in the program, then also delete it here.
+ VERSION=1.3
+-CFLAGS+=-Wall -O2 -DVERSION=\"$(VERSION)\"
+-LDFLAGS=
++CFLAGS+=-Wall
++CPPFLAGS+=-DVERSION=\"$(VERSION)\"
+ OBJS=setpwc.o
+ all: setpwc
+-setpwc: $(OBJS)
+-      $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o setpwc
+-      #
+-      # Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
+-
+ install: setpwc
+       cp setpwc /usr/bin
index 562a6b7419a67deaf25e0a41b8ae0079c0f6beff..cbc20cad7175b57e547858da1ac0d87aaae4b420 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
+
 inherit toolchain-funcs
 
 DESCRIPTION="Control various aspects of Philips (and compatible) webcams"
@@ -11,18 +12,13 @@ SRC_URI="http://www.vanheusden.com/setpwc/${P}.tgz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~arm ppc x86"
-IUSE=""
 
-RDEPEND=""
 DEPEND="sys-kernel/linux-headers"
 
-src_prepare() {
-       sed -i -e '/CFLAGS/s: -O2::' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
 
-src_compile() {
+src_configure() {
        tc-export CC
-       emake LDFLAGS="${LDFLAGS}"
 }
 
 src_install() {