net-fs/davfs2: add support for neon-0.31 #719954
authorGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 01:11:19 +0000 (21:11 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 01:26:36 +0000 (21:26 -0400)
Thanks thulle for the patch!

Closes: https://bugs.gentoo.org/719954
Package-Manager: Portage-2.3.69, Repoman-2.3.14
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
net-fs/davfs2/davfs2-1.5.6.ebuild
net-fs/davfs2/files/davfs2-1.5.6-neon31-support.patch [new file with mode: 0644]

index 320e82d5c52d7c9de96cdb806e736e73f1615406..6f227c812123f66a36dd78bbb41bd9bf6e58786b 100644 (file)
@@ -31,7 +31,8 @@ src_prepare() {
        sed -e '/^manual[58]_DATA/ s/\.gz//g' \
                -i "${S}"/man/Makefile.in || die
 
-       eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch
+       eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch \
+                  "${FILESDIR}"/${P}-neon31-support.patch
 
        default
 }
diff --git a/net-fs/davfs2/files/davfs2-1.5.6-neon31-support.patch b/net-fs/davfs2/files/davfs2-1.5.6-neon31-support.patch
new file mode 100644 (file)
index 0000000..1f5b0b3
--- /dev/null
@@ -0,0 +1,45 @@
+Update configure to support neon-0.31.1
+Bug: https://bugs.gentoo.org/719954
+
+--- a/configure
++++ b/configure
+@@ -6800,7 +6800,7 @@
+ $as_echo "$ne_cv_lib_neon" >&6; }
+     if test "$ne_cv_lib_neon" = "yes"; then
+        ne_cv_lib_neonver=no
+-       for v in 27 28 29 30; do
++       for v in 27 28 29 30 31; do
+           case $ne_libver in
+           0.$v.*) ne_cv_lib_neonver=yes ;;
+           esac
+@@ -6983,8 +6983,8 @@
+     neon_got_library=yes
+ else
+-    { $as_echo "$as_me:${as_lineno-$LINENO}: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
+-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
++    { $as_echo "$as_me:${as_lineno-$LINENO}: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&6;}
+     neon_got_library=no
+ fi
+@@ -7040,7 +7040,7 @@
+ $as_echo "$ne_cv_lib_neon" >&6; }
+     if test "$ne_cv_lib_neon" = "yes"; then
+        ne_cv_lib_neonver=no
+-       for v in 27 28 29 30; do
++       for v in 27 28 29 30 31; do
+           case $ne_libver in
+           0.$v.*) ne_cv_lib_neonver=yes ;;
+           esac
+@@ -7223,8 +7223,8 @@
+     neon_got_library=yes
+ else
+-    { $as_echo "$as_me:${as_lineno-$LINENO}: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
+-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
++    { $as_echo "$as_me:${as_lineno-$LINENO}: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&6;}
+     neon_got_library=no
+ fi