projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a2a264d
)
app-crypt/gnupg: fix bug #649598, USE=usb on prefix
author
Guilherme Amadio
<amadio@gentoo.org>
Thu, 23 Aug 2018 07:36:42 +0000
(09:36 +0200)
committer
Guilherme Amadio
<amadio@gentoo.org>
Thu, 23 Aug 2018 07:36:51 +0000
(09:36 +0200)
Closes: https://bugs.gentoo.org/649598
Suggested-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.47, Repoman-2.3.10
app-crypt/gnupg/gnupg-2.2.9.ebuild
patch
|
blob
|
history
diff --git
a/app-crypt/gnupg/gnupg-2.2.9.ebuild
b/app-crypt/gnupg/gnupg-2.2.9.ebuild
index d53de1b7125817dec5a948753c796933e7d13ce2..2345009acbcb0cd8502707639e6940e7b87c7d99 100644
(file)
--- a/
app-crypt/gnupg/gnupg-2.2.9.ebuild
+++ b/
app-crypt/gnupg/gnupg-2.2.9.ebuild
@@
-3,7
+3,7
@@
EAPI="6"
-inherit systemd toolchain-funcs
+inherit
flag-o-matic
systemd toolchain-funcs
MY_P="${P/_/-}"
@@
-65,6
+65,10
@@
src_configure() {
--enable-scdaemon
$(use_enable usb ccid-driver)
)
+ if use prefix && use usb ; then
+ # bug #649598
+ append-cppflags -I"${EPREFIX}/usr/include/libusb-1.0"
+ fi
else
myconf+=( --disable-scdaemon )
fi