dev-python/jeepney: 0.4.3 + QA
authorSebastian Pipping <sping@gentoo.org>
Sat, 28 Mar 2020 22:36:51 +0000 (23:36 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 28 Mar 2020 22:37:11 +0000 (23:37 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/jeepney/Manifest
dev-python/jeepney/jeepney-0.4.3.ebuild [new file with mode: 0644]

index 2dff6462c97dbe2ff76670ebfaf2eab7238aeacc..0818b68e7cf002132afbb40eb7f66ca584a0d56b 100644 (file)
@@ -1 +1,2 @@
 DIST jeepney-0.4.1.tar.gz 27706 BLAKE2B 152bf872621a0e023b9f44bb165113b2c3ef0037f66cb1c2aa15423d68ae5c295ad100aba855f061840054a25c3ed30a2d1faed09cf2130235df72c70738c791 SHA512 46aed19fd29df724af0e78ec0acabeb196324444e682817c330f3fd290a52cf6a6cb639f8c76f4ef5311817c4e051d7231b4f26af3cb6768bdd8c4bec7589210
+DIST jeepney-0.4.3.tar.gz 28121 BLAKE2B 2c9b5b5ec26a9af25d28af602827c73c8ec9377a88a4aa79b9a986675c1ef3f195763a338f3efa4ee371f7751dcf05a9f9cfed06c8d6677d81da3699773d5561 SHA512 bfb12c9259a57324759f8be44d1faf2c0535762e72db5f1370e64cb144c0fc537c9bc9cfb9b075932fb3a20e3ef4e0c990c10905cc5a69e3fb088e8de4193689
diff --git a/dev-python/jeepney/jeepney-0.4.3.ebuild b/dev-python/jeepney/jeepney-0.4.3.ebuild
new file mode 100644 (file)
index 0000000..4cb80cd
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+       test? ( dev-python/testpath[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+       dev-python/sphinx_rtd_theme
+
+python_install_all() {
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               dodoc -r examples
+       fi
+       distutils-r1_python_install_all
+}