x11-libs/cairo: Port to EAPI=7
authorMatt Turner <mattst88@gentoo.org>
Mon, 13 Jan 2020 17:51:43 +0000 (09:51 -0800)
committerMatt Turner <mattst88@gentoo.org>
Mon, 13 Jan 2020 18:13:24 +0000 (10:13 -0800)
Thanks to David Michael.

Closes: https://bugs.gentoo.org/705130
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/cairo/cairo-1.16.0-r3.ebuild
x11-libs/cairo/cairo-9999.ebuild

index b759d2048053fd6ed0c0fc9e89f7f0d53503e58b..1c3590a8d2a16b1e67bc1b117745b47ee5914ce8 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit eutils flag-o-matic autotools multilib-minimal
+inherit flag-o-matic autotools multilib-minimal
 
 if [[ ${PV} == *9999* ]]; then
        inherit git-r3
@@ -25,6 +25,9 @@ IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
 # Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
 RESTRICT="test"
 
+BDEPEND="
+       virtual/pkgconfig
+       >=sys-devel/libtool-2"
 RDEPEND="
        >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
        >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
@@ -45,8 +48,6 @@ RDEPEND="
                >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
        )"
 DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       >=sys-devel/libtool-2
        X? ( x11-base/xorg-proto )"
 #[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
 #      doc? (
@@ -127,6 +128,6 @@ multilib_src_configure() {
 }
 
 multilib_src_install_all() {
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
        einstalldocs
 }
index f2e28c9ed36486f94f01e9f398de1468b3003fac..6b69a9ab32b6d60cad85b441442508544b71bd07 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit eutils flag-o-matic autotools multilib-minimal
+inherit flag-o-matic autotools multilib-minimal
 
 if [[ ${PV} == *9999* ]]; then
        inherit git-r3
@@ -25,6 +25,9 @@ IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
 # Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
 RESTRICT="test"
 
+BDEPEND="
+       virtual/pkgconfig
+       >=sys-devel/libtool-2"
 RDEPEND="
        >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
        >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
@@ -45,8 +48,6 @@ RDEPEND="
                >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
        )"
 DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       >=sys-devel/libtool-2
        X? ( x11-base/xorg-proto )"
 #[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
 #      doc? (
@@ -125,6 +126,6 @@ multilib_src_configure() {
 }
 
 multilib_src_install_all() {
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
        einstalldocs
 }