net-ftp/pure-ftpd: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 5 Apr 2017 20:26:19 +0000 (22:26 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 5 Apr 2017 20:26:36 +0000 (22:26 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

net-ftp/pure-ftpd/Manifest
net-ftp/pure-ftpd/pure-ftpd-1.0.42-r1.ebuild [deleted file]

index 2628d0d126bcfb827bdd96e0e7ae4b9efdb1be03..7404fadde7dbe1e0ccb225fecb3835f8cc76cb8e 100644 (file)
@@ -1,2 +1 @@
-DIST pure-ftpd-1.0.42.tar.bz2 496652 SHA256 efd11295998453e31dbeef9159624beabbac2643a338134ae8c2ef529aa2ec10 SHA512 730ece22ce9a8562c5da6063de2b99404fbc0d0fa0b591383c319a762ea33cec74239474bcb56606b7af254dd76e31154f27a745df0c619932c9b8b4f150bc9c WHIRLPOOL bcbcd32fcfe10741f214559f7051bca302addc9bdc0a90a24e33a53c8103199a2eb40ea65e314fc66c59a47a479bd6774e332f4898d750c90b6dbf1bee01bcec
 DIST pure-ftpd-1.0.45.tar.bz2 497695 SHA256 9256db7e59abdba712f84581a3ec47cd5b039034c78825d9dc24ea4eecda7d20 SHA512 bb22b6b88778e2586411318905aa165e590185f7a87ac30761d6250f4de22a1deec6be5441926eae28011d3a5a923bad2ac366e237cc96a4d7932e3dbc9a1f2a WHIRLPOOL 4eebb19342d2580658cac7bb13cf6ecebf70ec5000336565aea6609204befe85a5a96aed1ad24ada6a3b187a4750194d7d4676ea4942f0aff3137b45c9cde139
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.42-r1.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.42-r1.ebuild
deleted file mode 100644 (file)
index 3bf8c7a..0000000
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils confutils flag-o-matic
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
-
-DESCRIPTION="Fast, production-quality, standard-conformant FTP server"
-HOMEPAGE="http://www.pureftpd.org/"
-SRC_URI="ftp://ftp.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2
-       http://download.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-
-IUSE="anondel anonperm anonren anonres caps charconv implicittls ldap libressl mysql noiplog pam paranoidmsg postgres resolveids selinux ssl sysquota vchroot xinetd"
-
-REQUIRED_USE="implicittls? ( ssl )"
-
-DEPEND="caps? ( sys-libs/libcap )
-       charconv? ( virtual/libiconv )
-       ldap? ( >=net-nds/openldap-2.0.25 )
-       mysql? ( virtual/mysql )
-       pam? ( virtual/pam )
-       postgres? ( dev-db/postgresql:= )
-       ssl? (
-               !libressl? ( >=dev-libs/openssl-0.9.6g:0=[-bindist] )
-               libressl? ( dev-libs/libressl:= )
-       )
-       sysquota? ( sys-fs/quota[-rpc] )
-       xinetd? ( virtual/inetd )"
-
-RDEPEND="${DEPEND}
-       dev-libs/libsodium:=
-       net-ftp/ftpbase
-       selinux? ( sec-policy/selinux-ftp )"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-1.0.28-pam.patch
-}
-
-src_configure() {
-       # adjust max user length to something more appropriate
-       # for virtual hosts. See bug #62472 for details.
-       sed -e "s:# define MAX_USER_LENGTH 32U:# define MAX_USER_LENGTH 127U:" \
-               -i "${S}/src/ftpd.h" || die "sed failed"
-
-       local my_conf=""
-
-       # Let's configure the USE-enabled stuff
-       enable_extension_without        "capabilities"          "caps"
-       enable_extension_with           "rfc2640"               "charconv"              0
-       enable_extension_with           "ldap"                  "ldap"                  0
-       enable_extension_with           "mysql"                 "mysql"                 0
-       enable_extension_with           "pam"                   "pam"                   0
-       enable_extension_with           "paranoidmsg"           "paranoidmsg"           0
-       enable_extension_with           "pgsql"                 "postgres"              0
-       enable_extension_with           "tls"                   "ssl"                   0
-       enable_extension_with           "implicittls"           "implicittls"           0
-       enable_extension_with           "virtualchroot"         "vchroot"               0
-       enable_extension_with           "sysquotas"             "sysquota"              0
-       enable_extension_without        "inetd"                 "xinetd"
-
-       # noiplog is a negative flag, we don't want that enabled by default,
-       # so we handle it manually, as confutils can't do that
-       use noiplog && my_conf="${my_conf} --without-iplogging"
-
-       # Those features are only configurable like this, see bug #179375.
-       use anondel && append-cppflags -DANON_CAN_DELETE
-       use anonperm && append-cppflags -DANON_CAN_CHANGE_PERMS
-       use anonren && append-cppflags -DANON_CAN_RENAME
-       use anonres && append-cppflags -DANON_CAN_RESUME
-       use resolveids && append-cppflags -DALWAYS_RESOLVE_IDS
-
-       # Do not auto-use SSP -- let the user select this.
-       export ax_cv_check_cflags___fstack_protector_all=no
-
-       econf \
-               --with-altlog \
-               --with-cookie \
-               --with-diraliases \
-               --with-extauth \
-               --with-ftpwho \
-               --with-language=${PUREFTPD_LANG:=english} \
-               --with-peruserlimits \
-               --with-privsep \
-               --with-puredb \
-               --with-quotas \
-               --with-ratios \
-               --with-throttling \
-               --with-uploadscript \
-               --with-virtualhosts \
-               --enable-largefile \
-               ${my_conf}
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       dodoc AUTHORS CONTACT ChangeLog FAQ HISTORY INSTALL README* NEWS
-
-       newconfd "${FILESDIR}/pure-ftpd.conf_d-3" ${PN}
-
-       if use implicittls ; then
-               sed -i '/^SERVER/s@21@990@' "${ED}"/etc/conf.d/${PN} \
-                       || die "Adjusting default server port for implicittls usage failed!"
-       fi
-
-       newinitd "${FILESDIR}/pure-ftpd.rc11" pure-ftpd
-
-       dodir /var/lib/run/${PN}
-
-       if use xinetd ; then
-               insinto /etc/xinetd.d
-               newins "${FILESDIR}/pure-ftpd.xinetd" pure-ftpd
-       fi
-
-       if use ldap ; then
-               insinto /etc/openldap/schema
-               doins pureftpd.schema
-               insinto /etc/openldap
-               insopts -m 0600
-               doins pureftpd-ldap.conf
-       fi
-}
-
-pkg_postinst() {
-       if [[ -z "${REPLACING_VERSIONS}" ]]; then
-               # This is a new installation
-               elog
-               elog "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file!"
-               elog
-               ewarn "It's *really* important to read the README provided with Pure-FTPd!"
-               ewarn "Check out http://download.pureftpd.org/pub/pure-ftpd/doc/README for general info"
-               ewarn "and http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS for SSL/TLS info."
-               ewarn
-               if use charconv ; then
-                       ewarn "Charset conversion is an *experimental* feature!"
-                       ewarn "Remember to set a valid charset for your filesystem in the configuration!"
-               fi
-       fi
-}