sys-devel/bin86: Don't use colons as sed delimiter
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 28 Apr 2020 05:42:51 +0000 (07:42 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 28 Apr 2020 05:42:51 +0000 (07:42 +0200)
Closes: https://bugs.gentoo.org/710340
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-devel/bin86/bin86-0.16.20-r2.ebuild
sys-devel/bin86/bin86-0.16.21.ebuild

index 9e0088919ee0cc4dbd4a09c7b44cbf057c57f6c3..ae8685567e437e5dac513ca5a46789c34b4ff8ed 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -17,11 +17,11 @@ IUSE=""
 
 src_prepare() {
        sed -i \
-               -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
-               -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
-               -e '/^INSTALL_OPTS/s:-s::' \
-               -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
-               -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+               -e '/^PREFIX/s|=.*|=$(DESTDIR)/usr|' \
+               -e '/^MANDIR/s|)/man/man1|)/share/man/man1|' \
+               -e '/^INSTALL_OPTS/s|-s||' \
+               -e "/^CFLAGS/s|=.*|=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}|" \
+               -e "/^LDFLAGS/s|=.*|=${LDFLAGS}|" \
                Makefile || die
        epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch \
                "${DISTDIR}"/${P}-fix_lilo_build.patch
index 3e67dfb8467dda20fafac2586754c2d6e7794bd4..ad7a6449a569d1d1f1b96ae20b942da28159f42c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -17,11 +17,11 @@ IUSE=""
 src_prepare() {
        use elibc_musl && CPPFLAGS="${CPPFLAGS} -U__linux__"
        sed -i \
-               -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
-               -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
-               -e '/^INSTALL_OPTS/s:-s::' \
-               -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
-               -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+               -e '/^PREFIX/s|=.*|=$(DESTDIR)/usr|' \
+               -e '/^MANDIR/s|)/man/man1|)/share/man/man1|' \
+               -e '/^INSTALL_OPTS/s|-s||' \
+               -e "/^CFLAGS/s|=.*|=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}|" \
+               -e "/^LDFLAGS/s|=.*|=${LDFLAGS}|" \
                Makefile || die
        epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
        eapply_user