dev-python/webassets: Bump to 2.0, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 10 Mar 2020 17:43:12 +0000 (18:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 10 Mar 2020 18:32:12 +0000 (19:32 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/webassets/Manifest
dev-python/webassets/webassets-2.0.ebuild [new file with mode: 0644]

index 871a80576754a9af4d0ca7a4bd77368f58d81b8e..1520f131cb558d95ec87e791b58b7b63857abfd8 100644 (file)
@@ -1 +1,2 @@
 DIST webassets-0.12.1.tar.gz 181402 BLAKE2B 907a4184e0274a9543bda2b7c2fdfeabef346b0920d98e04abbfb3b9858ecae3c0da32b65efe8e4b52d82ab938e182e2e37f005ba25afb1d62235dcc5bc9bee7 SHA512 1e65956afc63dd4bbf43b3b7e220ec6edb8d69d817c6361de67bf8fc7a90b34d3f7e4d0bae4cc45cb3fc043802d2e5d5c8a7cc87421186000212a36605fbc26e
+DIST webassets-2.0.tar.gz 185864 BLAKE2B 8aaa7091c27644c6c464d13d106218e28531415458e67696c0243943a92a3869e23c7ff0aa8461abb876a178e3ad44f4b47a5366edb885d308dd8ec0f17ad034 SHA512 6d62d4e5c1ed81a2d235c24776b632574f3670ae3d863c5f5a79d0e1afc7acfa7965e532b7975503df758dbe6c8dbd857b250a6ea8e4b414c8f1ae12fb8addd7
diff --git a/dev-python/webassets/webassets-2.0.ebuild b/dev-python/webassets/webassets-2.0.ebuild
new file mode 100644 (file)
index 0000000..5da3b13
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asset management for Python web development"
+HOMEPAGE="https://github.com/miracle2k/webassets"
+SRC_URI="https://github.com/miracle2k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# ^^ pypi tarball is missing tests
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# dev-ruby/sass confuses the tests, they expect 'sass' as the reference
+# compiler
+BDEPEND="
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               !!dev-ruby/sass
+       )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # webassets wants /usr/bin/babel from babeljs,
+       # but we have only one from openbabel
+       # ... and we don't have postcss
+       sed -i \
+               -e 's|\(TestBabel\)|No\1|' \
+               -e 's|\(TestAutoprefixer6Filter\)|No\1|' \
+               tests/test_filters.py || die
+
+       distutils-r1_python_prepare_all
+}