Moved from app-sci/fann to sci-mathematics/fann.
authorOlivier Fisette <ribosome@gentoo.org>
Tue, 28 Dec 2004 21:57:36 +0000 (21:57 +0000)
committerOlivier Fisette <ribosome@gentoo.org>
Tue, 28 Dec 2004 21:57:36 +0000 (21:57 +0000)
sci-mathematics/fann/ChangeLog [new file with mode: 0644]
sci-mathematics/fann/Manifest [new file with mode: 0644]
sci-mathematics/fann/fann-1.2.0.ebuild [new file with mode: 0644]
sci-mathematics/fann/files/digest-fann-1.2.0 [new file with mode: 0644]
sci-mathematics/fann/files/fann-1.2.0-setup.py [new file with mode: 0644]
sci-mathematics/fann/metadata.xml [new file with mode: 0644]

diff --git a/sci-mathematics/fann/ChangeLog b/sci-mathematics/fann/ChangeLog
new file mode 100644 (file)
index 0000000..1eca141
--- /dev/null
@@ -0,0 +1,16 @@
+# ChangeLog for app-sci/fann
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.1 2004/12/28 21:57:36 ribosome Exp $
+
+*fann-1.2.0 (28 Dec 2004)
+
+  28 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+  +files/fann-1.2.0-setup.py, +fann-1.2.0.ebuild:
+  Moved from app-sci/fann to sci-mathematics/fann.
+
+*fann-1.2.0 (04 Dec 2004)
+
+  04 Dec 2004; Christian Andreetta <satya@gentoo.org> +metadata.xml,
+  +files/fann-1.2.0-setup.py, +fann-1.2.0.ebuild:
+  initial ebuild
+
diff --git a/sci-mathematics/fann/Manifest b/sci-mathematics/fann/Manifest
new file mode 100644 (file)
index 0000000..efcb443
--- /dev/null
@@ -0,0 +1,5 @@
+MD5 7f71462c7f520e6adaa523e034f32a5d ChangeLog 360
+MD5 a1a8f7b84e93c6954c7a492419204578 metadata.xml 700
+MD5 52ac2e5a4653da9135c3a8e46b7773e8 fann-1.2.0.ebuild 2418
+MD5 2f3e1ec485ad30450d503501c4d67912 files/digest-fann-1.2.0 64
+MD5 c3136d6017e2e2debb0c8518543a9900 files/fann-1.2.0-setup.py 1503
diff --git a/sci-mathematics/fann/fann-1.2.0.ebuild b/sci-mathematics/fann/fann-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..f64c7f3
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0.ebuild,v 1.1 2004/12/28 21:57:36 ribosome Exp $
+
+inherit eutils
+#-----------------------------------------------------------------------------
+DESCRIPTION="Fast Artificial Neural Network Library implements multilayer artificial neural networks in C"
+HOMEPAGE="http://fann.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fann/${PF}.tar.bz2"
+#-----------------------------------------------------------------------------
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc python"
+#-----------------------------------------------------------------------------
+DEPEND="sys-devel/autoconf
+       sys-apps/sed
+       doc? ( app-text/docbook-sgml-utils )
+       python? ( dev-lang/python dev-lang/swig )"
+#-----------------------------------------------------------------------------
+S=${WORKDIR}/${PF}
+#=============================================================================
+src_unpack() {
+       unpack ${A} || die
+       cd ${S} || die
+       cp ${FILESDIR}/${PF}-setup.py ${S}/python/setup.py
+}
+#=============================================================================
+src_compile() {
+       local myconf
+       myconf="--prefix=/usr"
+       cd ${S} || die
+       econf ${myconf} || die
+       emake || die
+       if use python; then
+               einfo "python ------------------------------"
+               cd ${S}/python || die
+               mkdir fann
+               for f in `ls *py |grep -v setup.py`; do
+                       mv $f fann || die
+               done
+       fi
+}
+#=============================================================================
+src_install() {
+       cd ${S}
+       make install DESTDIR=${D} || die
+       if use doc; then
+               einfo "doc ---------------------------------"
+               dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+               insinto /usr/share/doc/${PF}/benchmarks
+               cp -a ${S}/benchmarks/* ${D}/usr/share/doc/${PF}/benchmarks
+               insinto /usr/share/doc/${PF}/examples/c
+               doins ${S}/examples/*
+               insinto /usr/share/doc/${PF}/html
+               cp -a doc/html/* ${D}/usr/share/doc/${PF}/html
+               insinto /usr/share/doc/${PF}/pdf
+               doins doc/*pdf
+       fi
+       if use python; then
+               einfo "python ------------------------------"
+               cd ${S}/python || die
+               python setup.py install --root=${D} || die "No python"
+               if use doc; then
+                       local python_doc_dir="/usr/share/doc/${PF}/examples/python"
+                       insinto ${python_doc_dir}
+                       doins examples/*py
+                       dosym ../../benchmarks/datasets ${python_doc_dir}/
+               fi
+       fi
+}
+
diff --git a/sci-mathematics/fann/files/digest-fann-1.2.0 b/sci-mathematics/fann/files/digest-fann-1.2.0
new file mode 100644 (file)
index 0000000..24559c7
--- /dev/null
@@ -0,0 +1 @@
+MD5 d655f82d4a47e4b697b0083fdaa78c71 fann-1.2.0.tar.bz2 2082660
diff --git a/sci-mathematics/fann/files/fann-1.2.0-setup.py b/sci-mathematics/fann/files/fann-1.2.0-setup.py
new file mode 100644 (file)
index 0000000..82e8e10
--- /dev/null
@@ -0,0 +1,46 @@
+from distutils.core import setup, Extension\r
+from distutils.command.install_data import install_data\r
+from compiler.pycodegen import compileFile\r
+import glob\r
+import distutils\r
+import distutils.sysconfig\r
+import distutils.core\r
+import os\r
+\r
+DISTUTILS_DEBUG="True"\r
+\r
+VERSION='1.2.0'\r
+\r
+LONG_DESCRIPTION="""\\r
+Fast Artificial Neural Network Library implements multilayer\r
+artificial neural networks with support for both fully connected\r
+and sparsely connected networks. It includes a framework for easy \r
+handling of training data sets. It is easy to use, versatile, well \r
+documented, and fast. \r
+"""\r
+\r
+setup(\r
+       name='pyfann',\r
+       description='Fast Artificial Neural Network Library (fann)',\r
+       long_description=LONG_DESCRIPTION,\r
+       version=VERSION,\r
+       author='Steffen Nissen',\r
+       author_email='lukesky@diku.dk',\r
+       maintainer='Gil Megidish',\r
+       maintainer_email='gil@megidish.net',\r
+       url='http://sourceforge.net/projects/fann/',\r
+       license='GNU LESSER GENERAL PUBLIC LICENSE (LGPL)',\r
+       # Description of the package in the distribution\r
+       packages=['fann'],\r
+       ext_package="fann",\r
+       ext_modules=[\r
+               Extension("_libfann", ["fann_helper.c","libfann.i"],\r
+                       include_dirs=["../src/include"],\r
+                       extra_link_args=['-L/usr/local/bin','-L/usr/bin','-L../src/include','-lpython2.3','-dll'],\r
+                               extra_objects=['/var/tmp/portage/fann-1.2.0/work/fann-1.2.0/src/fann_error.o',\r
+                                       '../src/fann_io.o','../src/fann.o','../src/fann_options.o',\r
+                                       '../src/fann_train_data.o','../src/fann_train.o'],\r
+                        )\r
+               ],\r
+       )\r
+\r
diff --git a/sci-mathematics/fann/metadata.xml b/sci-mathematics/fann/metadata.xml
new file mode 100644 (file)
index 0000000..7f24ade
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+       <email>satya@gentoo.org</email>
+       <name>Christian Andreetta</name>
+</maintainer>
+<longdescription>
+Fast Artificial Neural Network Library implements multilayer artificial neural networks in C with support for both fully connected and sparsely connected networks. Cross-platform execution in both fixed and floating point are supported. It includes a framework for easy handling of training data sets. It is easy to use, versatile, well documented, and fast. Delphi, PHP, Python and other bindings are available.
+</longdescription>
+</pkgmetadata>