net-libs/libssh2: Add RESTRICT=test
authorJeroen Roovers <jer@gentoo.org>
Fri, 5 Oct 2018 18:20:43 +0000 (20:20 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 5 Oct 2018 18:20:58 +0000 (20:20 +0200)
Many of the tests require app-emulation/docker to be set up and working.

Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/libssh2/libssh2-1.8.0-r2.ebuild

index 76496b69216c5fd94366c90bd73be3cf9f30c5b8..501d50e45694e03b751bdad6827b57a8bd9b5b69 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit cmake-utils multilib-minimal
+inherit cmake-multilib
 
 DESCRIPTION="Library implementing the SSH2 protocol"
 HOMEPAGE="https://www.libssh2.org"
@@ -11,10 +11,11 @@ SRC_URI="https://www.${PN}.org/download/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="gcrypt libressl mbedtls test zlib"
+IUSE="gcrypt libressl mbedtls zlib"
 REQUIRED_USE="
        ?? ( gcrypt libressl mbedtls )
 "
+RESTRICT="test"
 
 RDEPEND="
        !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
@@ -23,7 +24,9 @@ RDEPEND="
        mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
        zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
 "
-DEPEND="${RDEPEND}"
+DEPEND="
+       ${RDEPEND}
+"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-1.8.0-libgcrypt-prefix.patch