www-client/firefox: move pkg_pretend()
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:25:39 +0000 (23:25 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:35:16 +0000 (23:35 +0100)
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.5.0.ebuild
www-client/firefox/firefox-73.0.1.ebuild

index bceb3a0c22acdd7c5655a35b427d0093d8ea4d83..811f352adb1304002fd4edc5e54caa0587d3fd51 100644 (file)
@@ -212,15 +212,26 @@ llvm_check_deps() {
        einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
 }
 
-pkg_setup() {
-       moz_pkgsetup
-
+pkg_pretend() {
        if use pgo ; then
                if ! has usersandbox $FEATURES ; then
                        die "You must enable usersandbox as X server can not run as root!"
                fi
        fi
 
+       # Ensure we have enough disk space to compile
+       if use pgo || use lto || use debug || use test ; then
+               CHECKREQS_DISK_BUILD="8G"
+       else
+               CHECKREQS_DISK_BUILD="4G"
+       fi
+
+       check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+       moz_pkgsetup
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \
@@ -244,17 +255,6 @@ pkg_setup() {
        llvm_pkg_setup
 }
 
-pkg_pretend() {
-       # Ensure we have enough disk space to compile
-       if use pgo || use lto || use debug || use test ; then
-               CHECKREQS_DISK_BUILD="8G"
-       else
-               CHECKREQS_DISK_BUILD="4G"
-       fi
-
-       check-reqs_pkg_setup
-}
-
 src_unpack() {
        default
 
index ec9af7413fa0ceae19b98f5427f1c44b6c3378fa..6a7e5f80c0b4b69b7941a4124b7425a2cdd6e8a8 100644 (file)
@@ -204,15 +204,26 @@ llvm_check_deps() {
        einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
 }
 
-pkg_setup() {
-       moz_pkgsetup
-
+pkg_pretend() {
        if use pgo ; then
                if ! has usersandbox $FEATURES ; then
                        die "You must enable usersandbox as X server can not run as root!"
                fi
        fi
 
+       # Ensure we have enough disk space to compile
+       if use pgo || use lto || use debug || use test ; then
+               CHECKREQS_DISK_BUILD="8G"
+       else
+               CHECKREQS_DISK_BUILD="4G"
+       fi
+
+       check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+       moz_pkgsetup
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \
@@ -236,17 +247,6 @@ pkg_setup() {
        llvm_pkg_setup
 }
 
-pkg_pretend() {
-       # Ensure we have enough disk space to compile
-       if use pgo || use lto || use debug || use test ; then
-               CHECKREQS_DISK_BUILD="8G"
-       else
-               CHECKREQS_DISK_BUILD="4G"
-       fi
-
-       check-reqs_pkg_setup
-}
-
 src_unpack() {
        default