dev-java/jgoodies-animation: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 1 Apr 2019 09:05:41 +0000 (11:05 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 1 Apr 2019 09:06:39 +0000 (11:06 +0200)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
RepoMan-Options: --force

dev-java/jgoodies-animation/Manifest
dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild [new file with mode: 0644]

index f4a2bc9098d4be3fd2bdbf68d85d23d0d4c83f3c..a688a2ca5b6c9747650d8da2e37718f83f1eaa66 100644 (file)
@@ -1 +1,2 @@
 DIST animation-1_2_0.zip 728028 BLAKE2B 591b63b6a2799bfe6020c4e81b834807fba3e72a039dbd9954846b6c5a5c2445493e2d8814b1897b9465ec39c2b62c2f027c1e05ef7db5e9439acc236dbf9078 SHA512 2220630d7fd70a98b6d9605de7a1d6fc3470cc19b39815b9777e6bc8cf7db74ce77338861dde45aafbe336ce8b48ee00bcd8149af701a7001869cd3da3cf6a72
+DIST jgoodies-animation-1.2.0.zip 728028 BLAKE2B 591b63b6a2799bfe6020c4e81b834807fba3e72a039dbd9954846b6c5a5c2445493e2d8814b1897b9465ec39c2b62c2f027c1e05ef7db5e9439acc236dbf9078 SHA512 2220630d7fd70a98b6d9605de7a1d6fc3470cc19b39815b9777e6bc8cf7db74ce77338861dde45aafbe336ce8b48ee00bcd8149af701a7001869cd3da3cf6a72
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild
new file mode 100644 (file)
index 0000000..2ad9015
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_V=${PV//./_}
+
+DESCRIPTION="JGoodies Animation Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="mirror://gentoo/animation-${MY_V}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+       app-arch/unzip
+       >=virtual/jdk-1.6
+       test? ( dev-java/ant-junit:0 )"
+
+RDEPEND="
+       >=virtual/jre-1.6
+       examples? (
+               >=dev-java/jgoodies-binding-1.1:1.0
+               >=dev-java/jgoodies-forms-1.0:0
+       )"
+
+S="${WORKDIR}/animation-${PV}"
+
+EANT_FILTER_COMPILER="jikes"
+EANT_DOC_TARGET=""
+
+DOCS=( RELEASE-NOTES.txt README.html )
+
+src_prepare() {
+       default
+
+       java-pkg_clean
+}
+
+src_test() {
+       eant test -Djunit.jar.present=true \
+               -Djunit.jar=$(java-pkg_getjar junit junit.jar)
+}
+
+src_install() {
+       java-pkg_dojar build/animation.jar
+       einstalldocs
+       use doc && java-pkg_dohtml -r docs/*
+       use source && java-pkg_dosrc src/core/*
+       use examples && java-pkg_doexamples src/tutorial
+}