net-wireless/kismet: fix service
authorRick Farina <zerochaos@gentoo.org>
Thu, 13 Jun 2019 03:03:29 +0000 (23:03 -0400)
committerRick Farina <zerochaos@gentoo.org>
Thu, 13 Jun 2019 03:03:43 +0000 (23:03 -0400)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/kismet/files/kismet.confd-r1 [new file with mode: 0644]
net-wireless/kismet/files/kismet.initd-r1 [new file with mode: 0644]
net-wireless/kismet/kismet-9999.ebuild

diff --git a/net-wireless/kismet/files/kismet.confd-r1 b/net-wireless/kismet/files/kismet.confd-r1
new file mode 100644 (file)
index 0000000..42f6173
--- /dev/null
@@ -0,0 +1,14 @@
+# /etc/conf.d/kismet - configuration file for /etc/init.d/kismet
+
+# Kismet configuration is done in /etc/kismet*.conf
+# It is recommended to put user config in /etc/kismet_site.conf
+# where kismet updates won't try to overwrite it.
+
+# To use the kismet init script, you must have "logtemplate" set to a location
+# that is writable by the user assigned by "suiduser".
+# e.g.
+# suiduser=foo
+# logtemplate=%h/kismet_log/%n-%d-%i.%l
+
+# Options to pass to kismet, see `kismet --help`
+KISMET_SERVER_OPTIONS="--no-ncurses"
diff --git a/net-wireless/kismet/files/kismet.initd-r1 b/net-wireless/kismet/files/kismet.initd-r1
new file mode 100644 (file)
index 0000000..4c18916
--- /dev/null
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+checkconfig() {
+       if [ ! -e /etc/kismet.conf ]; then
+               eerror "Configuration file /etc/kismet.conf not found"
+               return 1
+       fi
+}
+
+start() {
+       checkconfig || return 1
+
+       ebegin "Starting kismet server"
+       start-stop-daemon --start --quiet --pidfile /run/kismet.pid \
+               --background --make-pidfile --exec /usr/bin/kismet \
+               -- ${KISMET_SERVER_OPTIONS}
+       eend ${?}
+}
+
+stop() {
+       ebegin "Stopping kismet server"
+       start-stop-daemon --stop --quiet --pidfile /run/kismet.pid
+       eend ${?}
+}
index 2ddf82ae347d93bcd659e08430b87f31ce5fcc39..ec7ea7c64b4ee43e55c35ef14a979b0508bf059c 100644 (file)
@@ -102,8 +102,8 @@ src_install() {
 
        #dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
        dodoc CHANGELOG README*
-       newinitd "${FILESDIR}"/${PN}.initd kismet
-       newconfd "${FILESDIR}"/${PN}.confd kismet
+       newinitd "${FILESDIR}"/${PN}.initd-r1 kismet
+       newconfd "${FILESDIR}"/${PN}.confd-r1 kismet
 }
 
 pkg_preinst() {