gnome-extra/gnome-shell-extensions: bump to 3.34.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 16:29:08 +0000 (18:29 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 16:32:06 +0000 (18:32 +0200)
Intentionally not newer yet, because it would slightly break
gnome-classic session, as 3.34.1 adapts to gnome-settings-daemon-3.34
component changes, while we don't have gsd-3.34 yet.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-shell-extensions/Manifest
gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.34.0.ebuild [new file with mode: 0644]

index 601352f0399af293db8d89fc1cd598f1f705002c..015fc62834ac6f32f32e92fbcd914a13ee7fa61f 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-shell-extensions-3.32.1.tar.xz 198320 BLAKE2B 416f77ea37431f8b806b8373f9a18091374f4b40b734375edfff2f673af50c073c3e3091e2b9b4be4241ebfa647b7f44b0f0f6e69460876feb7f90901e499a29 SHA512 e587a17eace87e05211bd4a0b8101a731054c99ba708051f6549c5e19974ccfeff75b0802d190d327f5ee8b4595c20e747d492f82c86aa76e0fc1cf3d20f0e4e
+DIST gnome-shell-extensions-3.34.0.tar.xz 204624 BLAKE2B 6d502927df71cc8bb25ea24b7431224518eb236cffc2cae329427e7dc76a9cbff2e3cea91108168b0cf82e2ba9784a2db21f38d5ca1ab18124219fe0786dab64 SHA512 ab2658acaff8e255575f36706d8d02754e58686546b609a72526fcc80ee02292fd6c0a078b89c34fdea9c2b1868e16d48f903741cff89e918f6fd2ed3d9ad193
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.34.0.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.34.0.ebuild
new file mode 100644 (file)
index 0000000..8697411
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org readme.gentoo-r1 meson xdg
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.26:2
+       >=gnome-base/libgtop-2.28.3[introspection]
+       >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${COMMON_DEPEND}
+       >=dev-libs/gjs-1.29
+       dev-libs/gobject-introspection:=
+       dev-libs/atk[introspection]
+       gnome-base/gnome-menus:3[introspection]
+       >=gnome-base/gnome-shell-3.34
+       <gnome-base/gnome-shell-3.35
+       media-libs/clutter:1.0[introspection]
+       net-libs/telepathy-glib[introspection]
+       x11-libs/gdk-pixbuf:2[introspection]
+       x11-libs/gtk+:3[introspection]
+       x11-libs/pango[introspection]
+       x11-themes/adwaita-icon-theme
+       >=x11-wm/mutter-3.32[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+       dev-lang/sassc
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       test? ( dev-lang/spidermonkey:60 )
+"
+
+RESTRICT="!test? ( test )"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweaks GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+       meson_src_configure \
+               -Dextension_set=all \
+               -Dclassic_mode=true
+}
+
+src_install() {
+       meson_src_install
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+
+       readme.gentoo_print_elog
+}