dev-ruby/shoulda-matchers: add ruby27
authorHans de Graaff <graaff@gentoo.org>
Mon, 13 Apr 2020 12:56:15 +0000 (14:56 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 13 Apr 2020 13:08:56 +0000 (15:08 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/shoulda-matchers/shoulda-matchers-4.3.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/shoulda-matchers/shoulda-matchers-4.3.0-r1.ebuild b/dev-ruby/shoulda-matchers/shoulda-matchers-4.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..5c7460d
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-matchers"
+SRC_URI="https://github.com/thoughtbot/shoulda-matchers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
+
+all_ruby_prepare() {
+       sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+       sed -i -e '/s.files/,/^  end/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}