dev-python/aiorpcX: Initial version
authorManuel Rüger <mrueg@gentoo.org>
Sun, 20 Jan 2019 16:58:59 +0000 (17:58 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 20 Jan 2019 16:59:05 +0000 (17:59 +0100)
Required as a dependency for net-misc/electrum-3.3.x

Package-Manager: Portage-2.3.56, Repoman-2.3.11
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
dev-python/aiorpcX/Manifest [new file with mode: 0644]
dev-python/aiorpcX/aiorpcX-0.10.2.ebuild [new file with mode: 0644]
dev-python/aiorpcX/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
new file mode 100644 (file)
index 0000000..dcc8eca
--- /dev/null
@@ -0,0 +1 @@
+DIST aiorpcX-0.10.2.tar.gz 23312 BLAKE2B 62d04099ae272369f29dea3a34a13b4b5cd6052764f2efee1f4a461b8ab52616e0cf69dde47a6f48c60827b3580d35bc39c87371d581a4a95147f5a5691e5111 SHA512 ebdc312c1c8d27382ca02ba6de5a316332b09bfba19399f9a4c3ef603a5d96becdfbed5c360d73aa64b41ecc5b0c3638822b0a5e49fd54c339b601c20add44ea
diff --git a/dev-python/aiorpcX/aiorpcX-0.10.2.ebuild b/dev-python/aiorpcX/aiorpcX-0.10.2.ebuild
new file mode 100644 (file)
index 0000000..d39a2a5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
diff --git a/dev-python/aiorpcX/metadata.xml b/dev-python/aiorpcX/metadata.xml
new file mode 100644 (file)
index 0000000..92df4ff
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">aiorpcX</remote-id>
+    <remote-id type="github">kyuupichan/aiorpcX</remote-id>
+  </upstream>
+</pkgmetadata>