dev-libs/libressl: initial import of version 2.2.3
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 11:28:59 +0000 (13:28 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 11:32:18 +0000 (13:32 +0200)
Gentoo-Bug: 508750

dev-libs/libressl/Manifest [new file with mode: 0644]
dev-libs/libressl/libressl-2.2.3.ebuild [new file with mode: 0644]
dev-libs/libressl/metadata.xml [new file with mode: 0644]

diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
new file mode 100644 (file)
index 0000000..c94beec
--- /dev/null
@@ -0,0 +1 @@
+DIST libressl-2.2.3.tar.gz 2967547 SHA256 a1ccc21adf91d60e99246031b99c930c9af5e1b1b5a61b1bec87beef6f16d882 SHA512 79f0cd57d2f1202e7d1213a9f9e0665bce11d1c1e5a4ba48c98b81f94e09a8c72733a5dfb0a5626b91db146641cfbec79acb9a5cbb437a60924b7f028d224500 WHIRLPOOL 1e8a49f7c491af558052257c0456b5c4d965abcfc8c7c274f7c42670f4f06a46d3e0360359fd19ecbbaf2fa461b80457e692eb2cb7b1a4bd92d0ad9a68e6663a
diff --git a/dev-libs/libressl/libressl-2.2.3.ebuild b/dev-libs/libressl/libressl-2.2.3.ebuild
new file mode 100644 (file)
index 0000000..e3b97b5
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+SLOT="0/35" # reflects ABI of libcrypto.so and libssl.so
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+       touch crypto/Makefile.in
+
+       sed -i \
+               -e '/^[ \t]*CFLAGS=/s#-g ##' \
+               -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+               -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+               configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable asm) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+       emake check
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       prune_libtool_files
+}
diff --git a/dev-libs/libressl/metadata.xml b/dev-libs/libressl/metadata.xml
new file mode 100644 (file)
index 0000000..4c35a8a
--- /dev/null
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <natural-name>LibreSSL</natural-name>
+       <longdescription lang="en">
+               LibreSSL is a version of the TLS/crypto stack forked from OpenSSL in
+               2014, with goals of modernizing the codebase, improving security, and
+               applying best practice development processes.
+       </longdescription>
+       <use>
+               <flag name="asm">Enables assembly</flag>
+       </use>
+       <upstream>
+               <changelog>http://www.libressl.org/releases.html</changelog>
+               <bugs-to>mailto:libressl@openbsd.org</bugs-to>
+               <bugs-to>https://github.com/libressl-portable/portable/issues</bugs-to>
+               <remote-id type="github">libressl-portable/portable</remote-id>
+       </upstream>
+</pkgmetadata>