net-analyzer/ntopng: Set Makefile overrides
authorJeroen Roovers <jer@gentoo.org>
Mon, 30 Dec 2019 09:21:46 +0000 (10:21 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 30 Dec 2019 09:23:11 +0000 (10:23 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/ntopng/ntopng-3.8.1-r2.ebuild [moved from net-analyzer/ntopng/ntopng-3.8.1-r1.ebuild with 94% similarity]

similarity index 94%
rename from net-analyzer/ntopng/ntopng-3.8.1-r1.ebuild
rename to net-analyzer/ntopng/ntopng-3.8.1-r2.ebuild
index 999edd283b2ea12126edcade0ad9a41d3c51e4ca..fb5e82a01945c9c5ffac7bb3048de5546a750c53 100644 (file)
@@ -64,6 +64,13 @@ src_configure() {
        default
 }
 
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               MYCFLAGS="${CFLAGS}" \
+               MYLDFLAGS="${LDFLAGS}"
+}
+
 src_install() {
        SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
        dodir ${SHARE_NTOPNG_DIR}