dev-php/pecl-ssh2: new v0.13 revision supporting PHP_TARGETS=php7-1.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 19:22:28 +0000 (15:22 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 19:27:24 +0000 (15:27 -0400)
The SLOT=0 for this package supports php-5.x, while SLOT=7 supports
php-7.x. To get them both installed at the same time, we use some
weird trickery. Long story short, we need to add a special case to
the SLOT=0 ebuild supporting "php7-1" in PHP_TARGETS.

The previous commit added php-7.1 support to the SLOT=7 ebuilds, and
this commit adds it to the SLOT=0 ebuild.

Gentoo-Bug: 603508

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild [moved from dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild with 64% similarity]

similarity index 64%
rename from dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild
rename to dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
index f41851e9648d46342058feaa9784d0f9c58f434b..df76f8cc3b8dae0d22213d8fa2e0f2d6cf8f0059 100644 (file)
@@ -1,13 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
 
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1"
 
 inherit php-ext-pecl-r3
 
@@ -18,10 +16,10 @@ LICENSE="PHP-3.01"
 SLOT="0"
 IUSE=""
 KEYWORDS="~amd64 ~x86"
-DEPEND=">=net-libs/libssh2-1.2"
+DEPEND="net-libs/libssh2"
 RDEPEND="${DEPEND}"
-PHP_EXT_ECONF_ARGS=""
-PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
+       php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
 
 src_prepare(){
        if use php_targets_php5-6 ; then