dev-java/java-sdk-docs: Version bump to 1.8.0.172
authorManuel Ullmann <labre@posteo.de>
Thu, 19 Apr 2018 19:29:17 +0000 (21:29 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 22 Apr 2018 23:01:41 +0000 (00:01 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Closes: https://bugs.gentoo.org/653564

dev-java/java-sdk-docs/Manifest
dev-java/java-sdk-docs/java-sdk-docs-1.8.0.172.ebuild [new file with mode: 0644]

index b08f305fd74de5e2559934e527080299ca700b8f..0e156a6e8621d81ea283e9e06348bcf443c3e2c2 100644 (file)
@@ -1,2 +1,3 @@
 DIST jdk-8u162-docs-all.zip 93476221 BLAKE2B bf871623cbf3bebd123edf73844d574cb9b88b4117a1c3a976654693e923c1a34249b5ef0c6c7812be29ed8581a1699b53536550583e666f844239ba554a1225 SHA512 944b93db6a2b471c2507786c45c50715222ad904c0f537c0e3cdf47a4b05ce560f8543377fe1c2217a79e064453aefdd70fafd32534131da2f246f6e39e60ebb
+DIST jdk-8u172-docs-all.zip 93491812 BLAKE2B 7d670aa054a73c9711b78b6094a8e4f8c8b8b774543a9b067acce7cb2e572d6536ad0c525d1ac112f2585a648b3209ac63df0d3ac85bf8c23ec91937b70add01 SHA512 6b1157822fd7d25bd4bb56394e8243e3e315ce772a908bb05fe260b5f1d6506f336b8afca6febef7caafcbf9463b4713fb27b657726ee4b6578d2e6732b9a2fe
 DIST jdk-9.0.4_doc-all.zip 70500089 BLAKE2B 549da2c6baf1b39082f05d42d0fd02f7682a765c1d43a605063b155b3b3e2e20053b4044a238afb41c758700efa5de9ec53c29e2e8be1d682c2e9e7b221c0875 SHA512 7d8b40499a0ea91ac922c6916b19a061b39e73e54e123a943fcaa75fcfe66672ad445dbd789c2c9448c8cee0e7f72974ca6ad53bcaa5667547feca5791dab92b
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.172.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.172.ebuild
new file mode 100644 (file)
index 0000000..4d414d1
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+       || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="jdk-${MY_PV}-docs-all.zip"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+       einfo "Please download ${SRC_URI} from"
+       einfo "${DOWNLOAD_URL}"
+       einfo "by agreeing to the license and place it in ${DISTDIR}"
+       einfo ""
+       einfo "If you find the file on the download page replaced with a higher"
+       einfo "version, please report it in bug #67266 (link below)."
+       einfo ""
+       einfo "If emerge fails because of a checksum error, it is possible that"
+       einfo "the upstream release changed without renaming. Try downloading the file"
+       einfo "again (or a newer revision if available). Otherwise report this to"
+       einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install() {
+       insinto /usr/share/doc/${PN}-${SLOT}/html
+       doins -r index.html */
+}