media-libs/rlottie: 2020-04-24 snapshot
authorJoonas Niilola <juippis@gentoo.org>
Wed, 29 Apr 2020 16:56:23 +0000 (19:56 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 29 Apr 2020 17:04:46 +0000 (20:04 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-libs/rlottie/Manifest
media-libs/rlottie/rlottie-0.0.1_pre20200424.ebuild [new file with mode: 0644]

index bcbbad8fb3b7c40ab897557fec2f150015a8f03d..de36b1952dd74548b0f3a5719714b76105e5d949 100644 (file)
@@ -1 +1,2 @@
 DIST rlottie-0.0.1_pre20200110.tar.gz 3370396 BLAKE2B 02a51e6f24a83967ccbf085e0c28400e23057c833e4849db3f749d30a3ccb4ade2d4e0a8ea624da7ba0148bc84013ca4df963f01fc75ed4156ab8dc36bda6945 SHA512 e78470254ab7b9653dcd95037001a1763f4229bdc611f4631943f302b20739a6e4b519d54c967c1ecd7bcc4b555bb8f651af0bceebc04cc9ea41789360b49af4
+DIST rlottie-0.0.1_pre20200424.tar.gz 3371620 BLAKE2B cdfc89f66e7aec736029416decf76777f22b4cb8293bed74e647088480faed4c6ffd03a29a967ac532f9e747858fdd93fa552eb974085f7cf1701a12fe3a2c38 SHA512 1a05b835c083337a80b32ea8c1e201d1d2356c58e314b791f74f95504303f3ef46d3951abf2a7467daaeae462c1fe2cf793d9fb2402639b279ca6ea6367cdda7
diff --git a/media-libs/rlottie/rlottie-0.0.1_pre20200424.ebuild b/media-libs/rlottie/rlottie-0.0.1_pre20200424.ebuild
new file mode 100644 (file)
index 0000000..26b4f6d
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="607998b9f7e03b05dceed8784207bd0b704f62d4"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL JSON LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/rlottie-0.0.1_pre20190920-disable-werror.patch )
+
+src_configure() {
+       local emesonargs=(
+               -D cache=true
+               -D cmake=false
+               -D dumptree=false
+               -D example=false
+               -D log=false
+               -D module=true
+               -D thread=true
+               $(meson_use test)
+       )
+
+       meson_src_configure
+}
+
+src_test() {
+       cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+       eninja test
+}