dev-lang/ghc: Switch/update remaining URLs
authorMichał Górny <mgorny@gentoo.org>
Fri, 8 Nov 2019 20:51:07 +0000 (21:51 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 15:13:50 +0000 (16:13 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/ghc/ghc-7.10.3.ebuild
dev-lang/ghc/ghc-7.8.4.ebuild
dev-lang/ghc/ghc-8.0.2.ebuild
dev-lang/ghc/ghc-8.2.1.ebuild
dev-lang/ghc/ghc-8.2.2.ebuild
dev-lang/ghc/ghc-8.4.1.ebuild
dev-lang/ghc/ghc-8.4.2.ebuild
dev-lang/ghc/ghc-8.4.3.ebuild
dev-lang/ghc/ghc-8.6.4.ebuild
dev-lang/ghc/ghc-8.6.5.ebuild
dev-lang/ghc/ghc-8.8.1.ebuild

index 8181b1c932455cc41307806b57c76749b26328da..7726e119c3c3a2c35cf790a6a2b52a72e2e924e2 100644 (file)
@@ -18,7 +18,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -58,7 +58,7 @@ GHC_PV=${PV}
 #GHC_PV=7.10.2.20151030 # uncomment only for -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.bz2 )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.bz2 )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -182,7 +182,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -257,11 +257,11 @@ ghc_setup_cflags() {
        gcc-specs-ssp && append-ghc-cflags persistent compile      -fno-stack-protector
 
        # prevent from failind building unregisterised ghc:
-       # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+       # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
        use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        # fix the similar issue as ppc64 TOC on ia64. ia64 has limited size of small data
        # currently ghc fails to build haddock
-       # http://osdir.com/ml/gnu.binutils.bugs/2004-10/msg00050.html
+       # https://osdir.com/ml/gnu.binutils.bugs/2004-10/msg00050.html
        use ia64 && append-ghc-cflags persistent compile -G0
 }
 
index dcd7b0f8a08e998380bc8c3e5a5d2de46cd77b96..937d25bc4fa8ded01dad54f24f12bf2aff59cbe9 100644 (file)
@@ -18,7 +18,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator
 
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -58,7 +58,7 @@ GHC_PV=${PV}
 #GHC_PV=7.8.3.20141119 # uncomment only for -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.bz2 )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.bz2 )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -177,11 +177,11 @@ ghc_setup_cflags() {
        gcc-specs-ssp && append-ghc-cflags persistent compile      -fno-stack-protector
 
        # prevent from failind building unregisterised ghc:
-       # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+       # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
        use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        # fix the similar issue as ppc64 TOC on ia64. ia64 has limited size of small data
        # currently ghc fails to build haddock
-       # http://osdir.com/ml/gnu.binutils.bugs/2004-10/msg00050.html
+       # https://osdir.com/ml/gnu.binutils.bugs/2004-10/msg00050.html
        use ia64 && append-ghc-cflags persistent compile -G0
 }
 
index 394a15972115f5c3e5103447beafa1146c485c96..6fe47f61c5f4890fd0853a6b0dbfeadd13400f4b 100644 (file)
@@ -18,7 +18,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -60,7 +60,7 @@ GHC_PV=${PV}
 #GHC_PV=8.0.1.20161213 # uncomment only for -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -255,7 +255,7 @@ ghc_setup_cflags() {
        fi
 
        # prevent from failind building unregisterised ghc:
-       # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+       # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
        use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
 }
 
index ca642a3830f99963b59558af5374a2623df7010f..266b59e2bfe82a38e63d38c96570d96a16430975 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -56,7 +56,7 @@ GHC_PV=${PV}
 #GHC_PV=8.2.0.20170704 # uncomment only for -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -260,7 +260,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index 4de85c302b7e0a30b580eb34e1cd0380497c23c0..6db8290ea34bbbfb2b8f081aa06c29ae9fa8bde5 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -56,7 +56,7 @@ GHC_PV=${PV}
 #GHC_PV=8.2.1.20171108 # uncomment only for -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -260,7 +260,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index bbff8dde2634b4ab4c1bb5afde09352afc159415..2fb1025b91f43ed0f12a036f99c1a704a4e7aa53 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -56,7 +56,7 @@ GHC_PV=${PV}
 #GHC_PV=8.4.0.20180224 # uncomment only for -alpha, -beta, -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -260,7 +260,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index 7c0065d00feb588b37dbb994777234f55feeeb34..529e6682ff971de471c4b5bb51fa77c3f9fc6b17 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -56,7 +56,7 @@ GHC_PV=${PV}
 #GHC_PV=8.4.1.20180329 # uncomment only for -alpha, -beta, -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -260,7 +260,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index e315edb423ea3ec79fb1ca215dfaac2e2a858c05..238882613374b417e5f64171bd9161310e4ad957 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -56,7 +56,7 @@ GHC_PV=${PV}
 #GHC_PV=8.4.1.20180329 # uncomment only for -alpha, -beta, -rc ebuilds
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz )"
 S="${WORKDIR}"/${GHC_P}
 
 [[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -260,7 +260,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index 03eca516b7e1ff2d2b792abd74c21a5133573f1e..85887f1f738a34c1af8882c952770ba2233d8126 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib multiprocessing pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -58,8 +58,8 @@ GHC_PV=${PV}
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
 SRC_URI="!binary? (
-       http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
-       test? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
+       https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
+       test? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
 )"
 S="${WORKDIR}"/${GHC_P}
 
@@ -186,7 +186,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -265,7 +265,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index 34f42ebdb2430588943c618d13e3f7c158982586..9ef1702b9c59ef8ad7dfc1422f4a8e953d482725 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib multiprocessing pax-utils toolchain-funcs versionator prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -58,8 +58,8 @@ GHC_PV=${PV}
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
 SRC_URI="!binary? (
-       http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
-       test? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
+       https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
+       test? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
 )"
 S="${WORKDIR}"/${GHC_P}
 
@@ -186,7 +186,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -265,7 +265,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }
index c53fccaeb533bc63ff5642ae0c411ee35b1d5177..571fd3176d33348d4fc2f731e07da54ad06c3dba 100644 (file)
@@ -17,7 +17,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
 inherit multilib multiprocessing pax-utils toolchain-funcs prefix
 inherit check-reqs
 DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
 
 # we don't have any binaries yet
 arch_binaries=""
@@ -58,8 +58,8 @@ GHC_PV=${PV}
 GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
 
 SRC_URI="!binary? (
-       http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
-       test? ( http://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
+       https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-src.tar.xz
+       test? ( https://downloads.haskell.org/~ghc/${PV/_/-}/${GHC_P}-testsuite.tar.xz )
 )"
 S="${WORKDIR}"/${GHC_P}
 
@@ -189,7 +189,7 @@ update_SRC_URI() {
                set -- $p
                pn=$1 pv=$2
 
-               SRC_URI+=" https://hackage.haskell.org/package/${pn}/${pn}-${pv}.tar.gz"
+               SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
        done
 }
 
@@ -268,7 +268,7 @@ ghc_setup_cflags() {
                fi
 
                # prevent from failing to build unregisterised ghc:
-               # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+               # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
                use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
        fi
 }