dev-java/gwt: Patch (by me) to not run git
authorMark Wright <gienah@gentoo.org>
Mon, 13 Jan 2020 02:55:49 +0000 (13:55 +1100)
committerMark Wright <gienah@gentoo.org>
Mon, 13 Jan 2020 02:57:31 +0000 (13:57 +1100)
Thanks to toralf for reporting.

Closes: https://bugs.gentoo.org/show_bug.cgi?id=705216
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mark Wright <gienah@gentoo.org>
dev-java/gwt/files/gwt-2.8.2-build-system.patch [new file with mode: 0644]
dev-java/gwt/gwt-2.8.2.ebuild

diff --git a/dev-java/gwt/files/gwt-2.8.2-build-system.patch b/dev-java/gwt/files/gwt-2.8.2-build-system.patch
new file mode 100644 (file)
index 0000000..8234041
--- /dev/null
@@ -0,0 +1,13 @@
+--- gwt-2.8.2-orig/common.ant.xml      2017-10-18 22:39:31.000000000 +1100
++++ gwt-2.8.2/common.ant.xml   2020-01-13 13:23:58.653719957 +1100
+@@ -277,9 +277,7 @@
+   <macrodef name="gwt.getgitinfo" description="Identifies the GIT info of a workspace">
+     <sequential>
+-      <exec executable="git" searchpath="true" outputproperty="gwt.gitrev">
+-        <arg line="rev-parse --short HEAD"/>
+-      </exec>
++      <property name="gwt.gitrev" value="faff18e7a1f065e3a4ac4ef32ab5cce394557070"/>
+       <!-- Generally, filtering requires a sentinel file so that changes to git rev will
+          be noticed as invalidating the previously-generated filter output.  This property
+          names where such a sentinel lives; it is tested with <available/> and created
index 3cc6b03863d1901dfc769ad6edbffdf4c351892e..0a0f40fa707ae0a1c1aab75b7c49b082a0f2dee6 100644 (file)
@@ -51,6 +51,11 @@ EANT_GENTOO_CLASSPATH="
                validation-api-1.0
 "
 
+src_prepare() {
+       eapply "${FILESDIR}"/${P}-build-system.patch
+       java-pkg-2_src_prepare
+}
+
 src_compile() {
        GWT_TOOLS="${WORKDIR}/${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}" \
                GWT_VERSION="${PV}" \