dev-python/bibtexparser: Version bump to 1.1.0
authorJonas Stein <jstein@gentoo.org>
Wed, 3 Jul 2019 20:43:23 +0000 (22:43 +0200)
committerJonas Stein <jstein@gentoo.org>
Wed, 3 Jul 2019 20:43:23 +0000 (22:43 +0200)
Version bump to 1.1.0
and EAPI=7

Package-Manager: Portage-2.3.68, Repoman-2.3.14
Signed-off-by: Jonas Stein <jstein@gentoo.org>
dev-python/bibtexparser/Manifest
dev-python/bibtexparser/bibtexparser-1.1.0.ebuild [new file with mode: 0644]

index 26d7af1f8820276cecb81ae04fb099438d93ba57..a2670d3c1936c4e77159e9afb7582bfaf31332dd 100644 (file)
@@ -1 +1,2 @@
 DIST bibtexparser-0.6.2.tar.gz 50876 BLAKE2B 660508717a224d1c1c28a52c8d7ccc8de7248e61b45ce73bb46729ee7feb8872bdaf92bd6b07cdfb7934fa57993b39749b9961185d4dc9cec2d55809761a783e SHA512 43a1c0475bc9e97c201a850e944f082e9eb316ac475cce4128b821008fc5b1597317f28c594f5462daee992b455fb4254fdf76a5baa02ff8e8a0e36f43c52491
+DIST bibtexparser-1.1.0.tar.gz 88656 BLAKE2B e5285953fbf79558643e19ea39f6421394f93afbfc6820be9bee0583c1efa010b9fe3478c9f3e36bea0c64e35c9d5bcb8341f1ee784c4150883e160723b94119 SHA512 f984cb307bfb8ee8143499469c0a83a28b3e9f061b17e5b43b7f9aa730c91427f2b2c441e501d37ab62f99ce2b7dd1cd7dee40b21c9f1a8e8b2dddf8eac2e74b
diff --git a/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild b/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..9d0a491
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="A BibTeX parser written in python"
+HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
+SRC_URI="https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/python-${P}"
+
+src_test() {
+       python_foreach_impl nosetests
+}