net-misc/openssh-8.2_p1-r6: Add patch to fix build with USE=hpn and libressl
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 17 Apr 2020 17:47:55 +0000 (10:47 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 17 Apr 2020 17:48:28 +0000 (10:48 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-misc/openssh/files/openssh-8.2_p1-hpn-14.20-libressl.patch [new file with mode: 0644]
net-misc/openssh/openssh-8.2_p1-r6.ebuild

diff --git a/net-misc/openssh/files/openssh-8.2_p1-hpn-14.20-libressl.patch b/net-misc/openssh/files/openssh-8.2_p1-hpn-14.20-libressl.patch
new file mode 100644 (file)
index 0000000..31796e7
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/openssh-8_1_P1-hpn-AES-CTR-14.20.diff    2020-04-17 10:31:37.392120799 -0700
++++ b/openssh-8_1_P1-hpn-AES-CTR-14.20.diff    2020-04-17 10:32:46.143684424 -0700
+@@ -672,7 +672,7 @@
+ +const EVP_CIPHER *
+ +evp_aes_ctr_mt(void)
+ +{
+-+# if OPENSSL_VERSION_NUMBER >= 0x10100000UL
+++# ifdef HAVE_OPAQUE_STRUCTS
+ +     static EVP_CIPHER *aes_ctr;
+ +     aes_ctr = EVP_CIPHER_meth_new(NID_undef, 16/*block*/, 16/*key*/);
+ +     EVP_CIPHER_meth_set_iv_length(aes_ctr, AES_BLOCK_SIZE);
+@@ -701,7 +701,7 @@
+ +             EVP_CIPH_ALWAYS_CALL_INIT | EVP_CIPH_CUSTOM_IV;
+ +#  endif /*SSH_OLD_EVP*/
+ +        return &aes_ctr;
+-+# endif /*OPENSSH_VERSION_NUMBER*/
+++# endif /*HAVE_OPAQUE_STRUCTS*/
+ +}
+ +
+ +#endif /* defined(WITH_OPENSSL) */
index 55d2852ebb936cf6bea4fc0cd89970d4937ffbaa..c0ed8f5dec46039673063e467820f802f43597db 100644 (file)
@@ -182,6 +182,7 @@ src_prepare() {
                cp $(printf -- "${DISTDIR}/%s\n" "${HPN_PATCHES[@]}") "${hpn_patchdir}" || die
                pushd "${hpn_patchdir}" &>/dev/null || die
                eapply "${FILESDIR}"/${P}-hpn-${HPN_VER}-glue.patch
+               eapply "${FILESDIR}"/${P}-hpn-${HPN_VER}-libressl.patch
                if use X509; then
                #       einfo "Will disable MT AES cipher due to incompatbility caused by X509 patch set"
                #       # X509 and AES-CTR-MT don't get along, let's just drop it