dev-python/pysrt: sync live ebuild with 1.1.1-r1
authorLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 23:14:25 +0000 (01:14 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 23:23:32 +0000 (01:23 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-python/pysrt/pysrt-9999.ebuild

index bda2f23780fd89a3c1eb7101d14874023504593a..5ceb7f70950202fdcc1171a8cef7d9ed3c4ba38f 100644 (file)
@@ -1,30 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
 
-inherit distutils-r1 git-r3
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
 
 DESCRIPTION="Python library used to edit or create SubRip files"
 HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
-EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+if [[ ${PV} == "9999" ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
 
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
 SLOT="0"
-KEYWORDS=""
 IUSE="test"
 
 RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               dev-python/nose[coverage(+),${PYTHON_USEDEP}]
                ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
        )
 "
 
 python_test() {
-       nosetests --with-coverage --cover-package=pysrt \
-               || die "Tests failed under ${EPYTHON}"
+       nosetests -v || die "Tests failed under ${EPYTHON}"
 }