net-im/coturn: version bump and chmod -x on initscript
authorAndreas Schuerch <nativemad@gentoo.org>
Fri, 3 Jan 2020 11:04:10 +0000 (12:04 +0100)
committerAndreas Schuerch <nativemad@gentoo.org>
Fri, 3 Jan 2020 11:04:10 +0000 (12:04 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
net-im/coturn/Manifest
net-im/coturn/coturn-4.5.1.1.ebuild [new file with mode: 0644]
net-im/coturn/coturn-9999.ebuild
net-im/coturn/files/turnserver.init [changed mode: 0755->0644]

index a8812e377e7fd02e52b48d34b5076a319a0eadc0..5484deb1c6e10d5038f4dc0868a7afe4896f4832 100644 (file)
@@ -1,2 +1,3 @@
 DIST coturn-4.5.0.7.tar.gz 396579 BLAKE2B ac66fbac772ad4b182f0c4b64178a780bfb364e4c1cf105fc340ac60da0a4c2e2b186c3ce08cade347a5d1a4b233bfed604db74eacd81967c3090e00bc1e36e8 SHA512 4e6e4efb456449752b2cd242c9be7c5dc2298472e338293d3de21c3a9da968f2f304625663372bb4d857c092c694aa4681630773a46e4928b9c60c69378adacc
 DIST coturn-4.5.0.8.tar.gz 403711 BLAKE2B 1bc6a145117ffb3a5ea7d6730524d0ad8857755a3d8a59588ec61df9fcf21c1c68a15efb588c73f659c4e855cb7fdce145a83a8a0e10c0bfae2d0a54d1120475 SHA512 2bf32f72223bcb1ee57254def423a6f6d385df8e20661f79a789b08324d432269eeeb4a6a551769f1f9147447bcf1b4471fc634e9d91ca979947119ae76cec9e
+DIST coturn-4.5.1.1.tar.gz 420069 BLAKE2B fe0e0334658d2a69132d7a83667ee52927e888f8978bd03eb099e61f17a4516d10a36d2abb1c93e2b25bc4192c342fba581b85892e99b139016e09c77a365cc2 SHA512 a5e1aecdab5a7060ffbc73cc8dd294cafa701f2e0d2a827e40901cb6001af5a2c5ecbafdf14662410713818aad0ad259133f0dc9b34730bf7911863e1e255f70
diff --git a/net-im/coturn/coturn-4.5.1.1.ebuild b/net-im/coturn/coturn-4.5.1.1.ebuild
new file mode 100644 (file)
index 0000000..9978e28
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils user systemd tmpfiles
+DESCRIPTION="coturn TURN server project"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+
+if [ ${PV} = 9999 ]; then
+       KEYWORDS=""
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit git-r3
+       DEPEND="dev-vcs/git"
+#      S="${WORKDIR}/${PN}-master"
+else
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="mongodb mysql postgres redis sqlite"
+RDEPEND="acct-group/turnserver
+        acct-user/turnserver
+        || ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
+        mongodb? ( dev-libs/mongo-c-driver )
+        mysql?  ( dev-db/mysql-connector-c )
+        postgres? ( dev-db/postgresql:* )
+        redis? ( dev-libs/hiredis )
+        sqlite? ( dev-db/sqlite )"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       sed 's:#log-file=/var/tmp/turn.log:log-file=/var/log/turnserver.log:' \
+           -i "${S}/examples/etc/turnserver.conf"  || die "sed for logdir failed"
+       sed 's:#simple-log:simple-log:' -i "${S}/examples/etc/turnserver.conf" \
+           || die "sed for simple-log failed"
+       if ! use mongodb; then
+               export TURN_NO_MONGO=yes
+       fi
+       if ! use mysql; then
+               export TURN_NO_MYSQL=yes
+       fi
+       if ! use postgres; then
+               export TURN_NO_PQ=yes
+       fi
+       if ! use redis; then
+               export TURN_NO_HIREDIS=yes
+       fi
+       if ! use sqlite; then
+               export TURN_NO_SQLITE=yes
+       fi
+
+       econf $(use_with sqlite)
+}
+
+src_install() {
+       default
+       newinitd "${FILESDIR}/turnserver.init" turnserver
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/logrotate.${PN}" "${PN}"
+       systemd_dounit "${FILESDIR}/${PN}.service"
+       dotmpfiles "${FILESDIR}/${PN}.conf"
+}
+
+pkg_postinst() {
+       tmpfiles_process "${PN}.conf"
+       elog "You need to copy /etc/turnserver.conf.default to"
+       elog "/etc/turnserver.conf and do your settings there."
+}
index a1fe9ad57b2cb94e9b8c4edb9fc3c7d000ab1911..9978e2829844c0aed8770a08c135fc04bd299c83 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 inherit eutils user systemd tmpfiles
 DESCRIPTION="coturn TURN server project"
 HOMEPAGE="https://github.com/${PN}/${PN}"
@@ -20,7 +20,9 @@ fi
 LICENSE="BSD"
 SLOT="0"
 IUSE="mongodb mysql postgres redis sqlite"
-RDEPEND="|| ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
+RDEPEND="acct-group/turnserver
+        acct-user/turnserver
+        || ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
         mongodb? ( dev-libs/mongo-c-driver )
         mysql?  ( dev-db/mysql-connector-c )
         postgres? ( dev-db/postgresql:* )
@@ -64,8 +66,6 @@ src_install() {
 
 pkg_postinst() {
        tmpfiles_process "${PN}.conf"
-       enewgroup turnserver
-       enewuser turnserver -1 -1 -1 turnserver
        elog "You need to copy /etc/turnserver.conf.default to"
        elog "/etc/turnserver.conf and do your settings there."
 }
old mode 100755 (executable)
new mode 100644 (file)
index 682e4f1..676fe10
@@ -1,5 +1,5 @@
 #!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2