dev-python/diskcache: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:46:43 +0000 (12:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:48:36 +0000 (12:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/diskcache/Manifest
dev-python/diskcache/diskcache-3.1.0.ebuild [deleted file]

index a6fee4ee67387d3249c03cdc902f8536dfb15bd0..539197ee3652102ab92ad2b0eb450c6aa8ca971e 100644 (file)
@@ -1,2 +1 @@
-DIST diskcache-3.1.0.tar.gz 489821 BLAKE2B 56b54662f31172f4f746ce885d57a3e9f34af9d7318300fe6906aee1b3373919f6ee33922ab30b7979cc6e271f2f780894438b4114483a7c76f198fb7b2213c1 SHA512 30ea3e6c1ed6430c1a7e3bf022bd9233e89a2486308d1f48f6e2f0b50ccc1ee50dade7c55d98a5611ef384bd193cd28f7e65f5737bae00845b17c159177dd345
 DIST diskcache-4.1.0.gh.tar.gz 658268 BLAKE2B 7712892a15e0f7b34b05c48071b4ed22f94ff4c8b6e66dff5591296d7186c686958ef3ec19994b6965319ba3e601850a1782f7ac8ed09090afda4b75ae16a12b SHA512 3871e56fa9a50942e29e200df74d7f4312d21a0f51d6be2041ce71efd3c1d0c204cc1df5ac1f92825314c742bb48bf8b0a3929cee225055903953e095701c8e3
diff --git a/dev-python/diskcache/diskcache-3.1.0.ebuild b/dev-python/diskcache/diskcache-3.1.0.ebuild
deleted file mode 100644 (file)
index 9e00a67..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/django[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
-       if use doc; then
-               emake -C docs html
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       nosetests -v || die "failed with ${PYTHON}"
-}