sci-mathematics/alt-ergo: fix build with ocaml-4.09
authorTupone Alfredo <tupone@gentoo.org>
Tue, 10 Mar 2020 21:37:53 +0000 (22:37 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 10 Mar 2020 21:37:53 +0000 (22:37 +0100)
Closes: https://bugs.gentoo.org/712032
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild

index 6dc8404508d20e16008366684ea347ca6c5f61b4..2f9029c56d083da6eca1bf275bb9af6317ac5e01 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -12,7 +12,7 @@ SLOT="0"
 KEYWORDS="amd64"
 IUSE="examples gtk +ocamlopt"
 
-DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt?]
        dev-ml/zarith
        gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
        dev-ml/camlzip
@@ -25,6 +25,11 @@ RDEPEND="${DEPEND}"
 
 DOCS=( CHANGES INSTALL.md README.md )
 
+src_prepare() {
+       default
+       find "${S}" -name \*.ml | xargs sed -i "s:Pervasives:Stdlib:g" || die
+}
+
 src_configure() {
        ./configure --prefix /usr --libdir=/usr/$(get_libdir)
 }