dev-python/vpython: initial import
authorAndrey Grozin <grozin@gentoo.org>
Tue, 20 Mar 2018 19:07:06 +0000 (02:07 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 20 Mar 2018 19:07:44 +0000 (02:07 +0700)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/vpython/Manifest [new file with mode: 0644]
dev-python/vpython/metadata.xml [new file with mode: 0644]
dev-python/vpython/vpython-7.4.2.ebuild [new file with mode: 0644]

diff --git a/dev-python/vpython/Manifest b/dev-python/vpython/Manifest
new file mode 100644 (file)
index 0000000..4730597
--- /dev/null
@@ -0,0 +1 @@
+DIST vpython-7.4.2.tar.gz 3960161 BLAKE2B e5a0d441f350af1b3390bea943fe5a5a9083234c415b93bf10bbc8109eb280050b447c95e93c18549f5c74a8c3ae43dfe6817cdc4055e4a8a7ad7f66b54c5342 SHA512 dd4db13743f733ac0bfcaac5520da193df9c0f7fc6198f1d55723e45a6e39f642f09f66a3f217669e70027a30c2f8426c0a80bee0d4cbc33b77ac5c927c7e3d0
diff --git a/dev-python/vpython/metadata.xml b/dev-python/vpython/metadata.xml
new file mode 100644 (file)
index 0000000..824d6a7
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>sci@gentoo.org</email>
+       </maintainer>
+       <longdescription>
+               This package enables one to run VPython in a browser,
+               using the GlowScript VPython API,
+               documented in the Help at http://glowscript.org.
+               If the code is in a cell in a Jupyter notebook,
+               the 3D scene appears in the Jupyter notebook.
+               If the code is launched outside a notebook (e.g. from the command line),
+               a browser window will open displaying the scene.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/vpython/vpython-7.4.2.ebuild b/dev-python/vpython/vpython-7.4.2.ebuild
new file mode 100644 (file)
index 0000000..f5ba2ba
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="http://www.vpython.org/ https://pypi.python.org/pypi/vpython/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/versioneer[${PYTHON_USEDEP}]
+       dev-python/jupyter[${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/autobahn[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"