sys-libs/compiler-rt: Fix Python branches more
authorMichał Górny <mgorny@gentoo.org>
Mon, 6 Jan 2020 20:58:04 +0000 (21:58 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 6 Jan 2020 21:00:46 +0000 (22:00 +0100)
Suggested by Arfrever.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild

index abb81deafce94e33af624cede44d031748c3f9ce..7a7778ae76b9aa86ae312488ed61e8792cff6da9 100644 (file)
@@ -33,6 +33,7 @@ BDEPEND="
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
+       use test || return 0
        has_version "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
@@ -45,7 +46,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       use test && python-any-r1_pkg_setup
+       python-any-r1_pkg_setup
 }
 
 test_compiler() {
index dc06a171993f01eb3757d56b57ced813640fd490..8339d3420ba3a5099a3340edbb6833b206682261 100644 (file)
@@ -37,6 +37,7 @@ S=${WORKDIR}/${P/_/}.src
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
+       use test || return 0
        has_version "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
@@ -49,7 +50,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       use test && python-any-r1_pkg_setup
+       python-any-r1_pkg_setup
 }
 
 test_compiler() {
index bad82273c1294489d14e1a31cd6d6b077911d739..5049bf3761b8ca8f403a0c8f2109992e8292d114 100644 (file)
@@ -38,6 +38,7 @@ S=${WORKDIR}/${MY_P}
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
+       use test || return 0
        has_version "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
@@ -50,7 +51,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       use test && python-any-r1_pkg_setup
+       python-any-r1_pkg_setup
 }
 
 test_compiler() {
index fb6ce9998fa72c88169c58055e3c23577803a996..55650e04a52ce4068e8412ff96aa41af6df79b78 100644 (file)
@@ -33,6 +33,7 @@ BDEPEND="
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
+       use test || return 0
        has_version "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
@@ -45,7 +46,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       use test && python-any-r1_pkg_setup
+       python-any-r1_pkg_setup
 }
 
 test_compiler() {