Version bump, removed old versions.
authorVlastimil Babka <caster@gentoo.org>
Thu, 14 Dec 2006 01:25:23 +0000 (01:25 +0000)
committerVlastimil Babka <caster@gentoo.org>
Thu, 14 Dec 2006 01:25:23 +0000 (01:25 +0000)
Package-Manager: portage-2.1.2_rc3-r4

dev-java/antlr/ChangeLog
dev-java/antlr/antlr-2.7.7.ebuild [new file with mode: 0644]
dev-java/antlr/files/digest-antlr-2.7.7 [new file with mode: 0644]

index 7eb884a0237f71ab1f903d46ea1175256ec22678..c44c20b9a966e3d8e03c781e612dad3caac15460 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-java/antlr
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.48 2006/12/07 22:52:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.49 2006/12/14 01:25:23 caster Exp $
+
+*antlr-2.7.7 (14 Dec 2006)
+
+  14 Dec 2006; Vlastimil Babka <caster@gentoo.org> -antlr-2.7.3.ebuild,
+  -antlr-2.7.4.ebuild, +antlr-2.7.7.ebuild:
+  Version bump, removed old versions.
 
   07 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> antlr-2.7.5-r3.ebuild:
   Add ~x86-fbsd keyword.
diff --git a/dev-java/antlr/antlr-2.7.7.ebuild b/dev-java/antlr/antlr-2.7.7.ebuild
new file mode 100644 (file)
index 0000000..bb358da
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.1 2006/12/14 01:25:23 caster Exp $
+
+inherit gnuconfig java-pkg-2 mono distutils multilib
+
+DESCRIPTION="A parser generator for C++, C#, Java, and Python"
+HOMEPAGE="http://www.antlr.org/"
+SRC_URI="http://www.antlr.org/download/${P}.tar.gz"
+
+LICENSE="ANTLR"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc debug examples mono nocxx nojava python script source"
+
+# TODO do we actually need jdk at runtime?
+RDEPEND=">=virtual/jdk-1.3
+       mono? ( dev-lang/mono )
+       python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+       script? ( !dev-util/pccts )
+       source? ( app-arch/zip )"
+
+src_compile() {
+       gnuconfig_update
+       # don't ask why, but this is needed for stuff to get built properly
+       # across the various JDKs
+       JAVACFLAGS="+ ${JAVACFLAGS}"
+
+       econf $(use_enable !nojava java) \
+               $(use_enable python) \
+               $(use_enable mono csharp) \
+               $(use_enable debug) \
+               $(use_enable examples) \
+               $(use_enable !nocxx cxx) \
+               --enable-verbose || die "configure failed"
+
+       emake || die "compile failed"
+
+       sed -e "s|@prefix@|/usr/|" \
+               -e 's|@exec_prefix@|${prefix}|' \
+               -e "s|@libdir@|\$\{exec_prefix\}/$(get_libdir)/antlr|" \
+               -e 's|@libs@|-r:\$\{libdir\}/antlr.astframe.dll -r:\$\{libdir\}/antlr.runtime.dll|' \
+               -e "s|@VERSION@|${PV}|" \
+               ${FILESDIR}/antlr.pc.in > ${S}/antlr.pc
+}
+
+src_install() {
+       exeinto /usr/bin
+       doexe ${S}/scripts/antlr-config
+
+       if ! use nocxx ; then
+               cd ${S}/lib/cpp
+               einstall || die "failed to install C++ files"
+       fi
+
+       if ! use nojava ; then
+               java-pkg_dojar ${S}/antlr/antlr.jar
+
+               use script && java-pkg_dolauncher antlr --main antlr.Tool
+
+               use source && java-pkg_dosrc ${S}/antlr
+               use doc && java-pkg_dohtml -r doc/*
+       fi
+
+       if use mono ; then
+               cd ${S}/lib
+
+               dodir /usr/$(get_libdir)/antlr/
+               insinto /usr/$(get_libdir)/antlr/
+
+               doins antlr.astframe.dll
+               doins antlr.runtime.dll
+
+               insinto /usr/$(get_libdir)/pkgconfig
+               doins ${S}/antlr.pc
+       fi
+
+       if use python ; then
+               cd ${S}/lib/python
+               distutils_src_install
+       fi
+
+       if use examples ; then
+               find ${S}/examples -iname Makefile\* -exec rm \{\} \;
+
+               dodir /usr/share/doc/${PF}/examples
+               insinto /usr/share/doc/${PF}/examples
+
+               ! use cxx && doins -r ${S}/examples/cpp
+               use java && doins -r ${S}/examples/java
+               use mono && doins -r ${S}/examples/csharp
+               use python && doins -r ${S}/examples/python
+       fi
+
+       newdoc ${S}/README.txt README
+}
diff --git a/dev-java/antlr/files/digest-antlr-2.7.7 b/dev-java/antlr/files/digest-antlr-2.7.7
new file mode 100644 (file)
index 0000000..f6437f4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 01cc9a2a454dd33dcd8c856ec89af090 antlr-2.7.7.tar.gz 1816180
+RMD160 0b7951a28b748e912721fe0f6de4095d9f8da57d antlr-2.7.7.tar.gz 1816180
+SHA256 853aeb021aef7586bda29e74a6b03006bcb565a755c86b66032d8ec31b67dbb9 antlr-2.7.7.tar.gz 1816180