dev-php/libvirt-php: Update live build, bug #588218
authorMatthias Maier <tamiko@gentoo.org>
Tue, 16 Aug 2016 03:04:52 +0000 (22:04 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 16 Aug 2016 05:22:04 +0000 (00:22 -0500)
Thanks to Michal Privoznik for the updated ebuild

Package-Manager: portage-2.2.28

dev-php/libvirt-php/libvirt-php-9999.ebuild

index f599904d1c9ffc1839ced370c95055825954d2eb..737b997886427acf96e069e63ee7e3b8c4ce70b6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=5
 
 PHP_EXT_NAME="libvirt-php"
 PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php5-6 php5-5 php5-4"
+USE_PHP="php5-6 php5-5"
 # Automake 1.14 is broken.  Check this later
 WANT_AUTOMAKE="1.13"
 
@@ -22,7 +22,8 @@ KEYWORDS=""
 IUSE="doc"
 
 RDEPEND="app-emulation/libvirt
-       dev-libs/libxml2"
+       dev-libs/libxml2
+       dev-php/pecl-imagick"
 DEPEND="${RDEPEND}
        dev-libs/libxslt
        doc? ( app-text/xhtml1 )"
@@ -53,7 +54,7 @@ src_install() {
        for slot in $(php_get_slots); do
                php_init_slot_env ${slot}
                insinto "${EXT_DIR}"
-               newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+               newins "src/.libs/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
        done
        php-ext-source-r2_createinifiles
        dodoc AUTHORS ChangeLog NEWS README