dev-python/libpillowfight: 0.3.0 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 14 Oct 2019 20:54:15 +0000 (22:54 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 14 Oct 2019 21:04:02 +0000 (23:04 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
dev-python/libpillowfight/Manifest
dev-python/libpillowfight/libpillowfight-0.3.0.ebuild [new file with mode: 0644]

index 0f318db4ad479321f0db901625f98c8c2e59cdad..7cc0bc8efbead32582a5d7e9fa6d38e49557f206 100644 (file)
@@ -1 +1,2 @@
 DIST pypillowfight-0.2.4.tar.gz 39411 BLAKE2B a890305e3c1650274426faf92178ca0b3742c413deac236a5ac23cb5ce9be372085cebfd7189a5e16e6f2176b5850c865cbfc899a036aedfad58c5f5fe08502a SHA512 440b0faccb9f393126306afb2a060e5dab5e68a02822ad4846498a2a6b07013837642cfb818b669820b268342be3c5b0ebed81f1e3265e1f383d74c1cfb16187
+DIST pypillowfight-0.3.0.tar.gz 41065 BLAKE2B 8e945bb5a96d7ebd610435fd868d12df371c29fbc26a9c57152988a990ad83daf70382bb94e8b5591144e18d6c54702c0a578ea5f29044fcdadd169effcf933c SHA512 2782030eabb665d20cf49de584220fb65417616c3a0e2a0376c91dc2c228b571768ea3a248ebd5ec4d244a1b825e98609a35b736f7f2fdbb3f674b08e891d9a7
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..dd2d0d9
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="pypillowfight"
+
+DESCRIPTION="Small library containing various image processing algorithms"
+HOMEPAGE="https://github.com/openpaperwork/libpillowfight"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_prepare_all() {
+       sed -e "/'nose>=1.0'/d" -i setup.py || die
+       distutils-r1_python_prepare_all
+}