net-firewall/fwknop: Switch to python-single-r1
authorMichał Górny <mgorny@gentoo.org>
Sat, 8 Feb 2020 11:59:34 +0000 (12:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 15:54:20 +0000 (16:54 +0100)
Switch to python-single-r1 since the dependency net-firewall/firewalld
is single-r1.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-firewall/fwknop/fwknop-2.6.10-r1.ebuild [moved from net-firewall/fwknop/fwknop-2.6.10.ebuild with 94% similarity]
net-firewall/fwknop/fwknop-2.6.9-r1.ebuild

similarity index 94%
rename from net-firewall/fwknop/fwknop-2.6.10.ebuild
rename to net-firewall/fwknop/fwknop-2.6.10-r1.ebuild
index 41a07f7c1a83e07f0ce2ae575b4b15d7e512daab..52c57d2312c0c4bf988dafaf4821634885a3cfc3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -6,6 +6,7 @@ EAPI=7
 # Python extension supports only Python 2.
 # See https://github.com/mrash/fwknop/issues/167
 PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
 DISTUTILS_OPTIONAL=1
 
 inherit autotools distutils-r1 eutils linux-info readme.gentoo-r1 systemd
@@ -21,7 +22,7 @@ IUSE="+client extras firewalld gdbm gpg +iptables nfqueue python +server udp-ser
 
 DEPEND="
        client? ( net-misc/wget[ssl] )
-       firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
+       firewalld? ( net-firewall/firewalld[${PYTHON_SINGLE_USEDEP}] )
        gdbm? ( sys-libs/gdbm )
        gpg? (
                app-crypt/gpgme
@@ -54,6 +55,11 @@ You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
 instead of the default one chosen at compile time.
 "
 
+pkg_setup() {
+       linux-info_pkg_setup
+       python-single-r1_pkg_setup
+}
+
 src_prepare() {
        default_src_prepare
 
index 5c86df5bfb0c95491609f0b666d78409c784ac11..03699570bd46f160317fa786ca087f330c370b07 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -7,6 +7,7 @@ EAPI=6
 # See https://github.com/mrash/fwknop/issues/167
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_OPTIONAL=1
+DISTUTILS_SINGLE_IMPL=1
 
 inherit autotools distutils-r1 eutils linux-info readme.gentoo-r1 systemd
 
@@ -21,7 +22,7 @@ IUSE="+client extras firewalld gdbm gpg +iptables nfqueue python +server udp-ser
 
 DEPEND="
        client? ( net-misc/wget[ssl] )
-       firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
+       firewalld? ( net-firewall/firewalld[${PYTHON_SINGLE_USEDEP}] )
        gdbm? ( sys-libs/gdbm )
        gpg? (
                app-crypt/gpgme
@@ -54,6 +55,11 @@ You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
 instead of the default one chosen at compile time.
 "
 
+pkg_setup() {
+       linux-info_pkg_setup
+       python-single-r1_pkg_setup
+}
+
 src_prepare() {
        default_src_prepare