media-sound/dcd: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:39 +0000 (13:39 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:39 +0000 (13:39 +0200)
Bug: https://bugs.gentoo.org/697274
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/dcd/dcd-0.95.ebuild
media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch [new file with mode: 0644]
media-sound/dcd/files/dcd-0.95-makefile.patch

index 9d4faecdeaa9febbfd41056d38f0e058f4ae63d8..0f9f329da3fff97a65a6120bd78f4ac4920bbc27 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="A simple command-line based CD Player"
 HOMEPAGE="http://www.technopagan.org/dcd"
@@ -12,20 +12,21 @@ SRC_URI="http://www.technopagan.org/dcd/${P}.tar.bz2"
 LICENSE="GPL-2 LGPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 ~ppc ppc64 sparc x86"
-IUSE=""
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=(
+       "${FILESDIR}"/${P}-makefile.patch
+       "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
 
 src_compile() {
-       emake CC="$(tc-getCC)" CDROM="/dev/cdrom" EXTRA_CFLAGS="${CFLAGS}" || die "emake failed"
+       emake \
+               CC="$(tc-getCC)" \
+               CDROM="/dev/cdrom" \
+               EXTRA_CFLAGS="${CFLAGS}"
 }
 
 src_install() {
-       dobin dcd || die "dobin failed"
+       dobin dcd
+       einstalldocs
        doman dcd.1
-       dodoc README BUGS ChangeLog
 }
diff --git a/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
new file mode 100644 (file)
index 0000000..d316042
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/dcd.c
++++ b/dcd.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <getopt.h>
++#include <time.h>
+ #define ZERO 0
+ #define MAX_TRACKS 103
+--- a/screenop.c
++++ b/screenop.c
+@@ -10,6 +10,7 @@
+ #include "cdindex.h"
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ void disk_directory(void) {
+   u_char ct = cd_current_track();
index b59fedb6180cd4fc053cb7d3affb1340ebb82f7a..c5ea478beb1d6eda1a8461241582c0c9bab98f72 100644 (file)
@@ -1,7 +1,5 @@
-Index: dcd-0.95/Makefile
-===================================================================
---- dcd-0.95.orig/Makefile
-+++ dcd-0.95/Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -114,7 +114,7 @@ all: ${PROGS}
        $(CC) -c $(CFLAGS) ${EXTRA_CFLAGS} $< -o $@