dev-python/brython: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 9 Feb 2018 10:54:46 +0000 (11:54 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 9 Feb 2018 10:54:46 +0000 (11:54 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/brython/Manifest
dev-python/brython/brython-3.3.5.ebuild [new file with mode: 0644]

index b4f5c9eedab47e8345baaba93302503371568c5f..345283e89fee74b89066c99fda9e8d2c15ed0190 100644 (file)
@@ -1,2 +1,3 @@
 DIST brython-3.3.3.zip 10040987 BLAKE2B a6a238ac6189e9170653c1987db46f2e0735f25deccaf0318ebc669b48dce1330acf333ef27300f1061e7e18044cfa24fadc02265d0fe3a83d0aa8b97f4de684 SHA512 e182a6c859cd18b90b205f751260b0b5c8d250746e48844c59cd61608dfdaf0fd6f0f25b8061de9505b7c5d094ac68fe57536c52cb31adb48f04c2cc5624e249
 DIST brython-3.3.4.zip 10047374 BLAKE2B ba4719476206fd71f412d646deb6a7eea3a0aef930814d7fa3589a3e736818f2bc7edf7f642998ae1471da87e3ad05ce89fd9dd32d569267ba45174543e4e520 SHA512 818181e040eefaeffd1e8866af471626ff5874fd99c3ee9fcc09c46a4b4b836619045a2712a8e16121a1132c86407b0676a8125e707eff4c7e867851cf20cecd
+DIST brython-3.3.5.tar.gz 9215864 BLAKE2B 985671d9d60396101b01813b151798d57ca8b7e6450c9a0eae2f14e65cf06cd12e416715219128ac17ff8fa66f1aa3e736dcbfb17537140b7373598d4c873eb1 SHA512 5226d01e4d0f824885329403e2d9b80dd0bec3ed456102f54fcb3900ff08508e3268111b51b892687db21f2936d4feb4bfd328775812206790bcccb4d9e366a8
diff --git a/dev-python/brython/brython-3.3.5.ebuild b/dev-python/brython/brython-3.3.5.ebuild
new file mode 100644 (file)
index 0000000..50f67db
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+       webapp_pkg_setup
+       python-single-r1_pkg_setup
+}
+
+src_install() {
+       dodoc LICENCE.txt README.md
+       rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+       webapp_src_preinst
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       webapp_src_install
+}