Replace identical versions with the sourceforge variant.
authorAlin Năstac <mrness@gentoo.org>
Sat, 18 Nov 2006 12:08:46 +0000 (12:08 +0000)
committerAlin Năstac <mrness@gentoo.org>
Sat, 18 Nov 2006 12:08:46 +0000 (12:08 +0000)
Package-Manager: portage-2.1.1-r1

net-dialup/mingetty/ChangeLog
net-dialup/mingetty/files/digest-mingetty-1.07 [new file with mode: 0644]
net-dialup/mingetty/mingetty-1.07.ebuild [new file with mode: 0644]

index e79f6b4de6e78891ac180b9ab64269ab9bfd5e3c..4cf07c04cc5d57ab281608c7c8f7cd22d302e93e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-dialup/mingetty
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/ChangeLog,v 1.37 2006/11/04 20:21:59 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/ChangeLog,v 1.38 2006/11/18 12:08:46 mrness Exp $
+
+*mingetty-1.07 (18 Nov 2006)
+
+  18 Nov 2006; Alin Nastac <mrness@gentoo.org> +mingetty-1.07.ebuild,
+  -mingetty-1.07.3.ebuild, -mingetty-1.07.5.ebuild:
+  Replace identical versions with the sourceforge variant.
 
   04 Nov 2006; Alexander H. Færøy <eroyf@gentoo.org>
   mingetty-1.07.5.ebuild:
diff --git a/net-dialup/mingetty/files/digest-mingetty-1.07 b/net-dialup/mingetty/files/digest-mingetty-1.07
new file mode 100644 (file)
index 0000000..991e29e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 72e4bce381908556ede9c3f959d1ca7a mingetty-1.07.tar.gz 13435
+RMD160 91d03c8a704af754137a6b61260c9925e602a121 mingetty-1.07.tar.gz 13435
+SHA256 f84dff06f1b0f449794c7b59be81128624f233dec049b48668457875935f871d mingetty-1.07.tar.gz 13435
diff --git a/net-dialup/mingetty/mingetty-1.07.ebuild b/net-dialup/mingetty/mingetty-1.07.ebuild
new file mode 100644 (file)
index 0000000..807eac4
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/mingetty-1.07.ebuild,v 1.1 2006/11/18 12:08:46 mrness Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A compact getty program for virtual consoles only."
+HOMEPAGE="http://sourceforge.net/projects/mingetty"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+IUSE=""
+
+src_compile() {
+       emake CFLAGS="${CFLAGS} -Wall -W -pipe -D_GNU_SOURCE" CC="$(tc-getCC)" || die "compile failed"
+}
+
+src_install () {
+       dodir /sbin /usr/share/man/man8
+       emake DESTDIR="${D}" install || die "install failed"
+}