net-libs/libmicrodns: Bump to 0.1.2
authorAdam Feldman <NP-Hardass@gentoo.org>
Sat, 11 Apr 2020 20:15:51 +0000 (16:15 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Sat, 11 Apr 2020 20:16:33 +0000 (16:16 -0400)
Bug: https://bugs.gentoo.org/714606
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
net-libs/libmicrodns/Manifest
net-libs/libmicrodns/libmicrodns-0.1.2.ebuild [new file with mode: 0644]
net-libs/libmicrodns/libmicrodns-9999.ebuild

index 3f931cdd49daaf206606d7e31fd59ea7c5e8c180..f320b7e331673fabbae74922253a0cdab982d7b3 100644 (file)
@@ -1 +1,2 @@
 DIST libmicrodns-0.0.9.tar.gz 57333 BLAKE2B a9e1d099d4588863dee3c2735a2e3f9cd46212729c342e06cccad1a8e997e85964e7f917ce97f50c0cccd21c1662ef9baf7392333ea666ff65b0577f57bab692 SHA512 6f7dbf1a324fed847131745498895ab0773dfc3c7bb96a05bf0fd3df0c0ce19d7f607789f7a5350d34e91e7ba323ee57196eb37ce351f83a9faa82c5fc8d89a8
+DIST microdns-0.1.2.tar.xz 49420 BLAKE2B 247a82c3bb038487390ba967387e9d4cec638ee5315290387c5b8863afbd45cc0700a3ee6c0308db253a161b5c1d345f77808de96df3f31bfaa2ff74e8fa3c05 SHA512 a6b15c65c74560fdba8973c63ffae9cdde4445f54196bb2d7d6348f6c15f8f162ef0a4e91b969ea3f2a60c701c3cc72799fcfba2fbf08c37f71ba8d5e3409702
diff --git a/net-libs/libmicrodns/libmicrodns-0.1.2.ebuild b/net-libs/libmicrodns/libmicrodns-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..0e1d2c1
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Minimal mDNS resolver (and announcer) library"
+HOMEPAGE="https://videolabs.io"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/videolabs/${PN}"
+else
+       SRC_URI="https://github.com/videolabs/${PN}/releases/download/${PV}/${P/lib/}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/${P/lib/}"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+       local emesonargs=(
+               $(meson_feature examples)
+               $(meson_feature test tests)
+       )
+       meson_src_configure
+}
index fbd51b90d87fc78291294f29f825e803cded3c11..0e1d2c1f619f16949e835b7bd6c3515ca0c92ab3 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit autotools
+inherit meson
 
 DESCRIPTION="Minimal mDNS resolver (and announcer) library"
 HOMEPAGE="https://videolabs.io"
@@ -12,18 +12,24 @@ if [[ ${PV} == 9999 ]]; then
        inherit git-r3
        EGIT_REPO_URI="https://github.com/videolabs/${PN}"
 else
-       SRC_URI="https://github.com/videolabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/videolabs/${PN}/releases/download/${PV}/${P/lib/}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/${P/lib/}"
 fi
 
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
 SLOT="0"
-IUSE=""
+IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 DEPEND=""
 RDEPEND="${DEPEND}"
+BDEPEND=""
 
-src_prepare() {
-       default
-       eautoreconf
+src_configure() {
+       local emesonargs=(
+               $(meson_feature examples)
+               $(meson_feature test tests)
+       )
+       meson_src_configure
 }