New development snapshot.
authorKeri Harris <keri@gentoo.org>
Sat, 17 Jun 2006 09:41:26 +0000 (09:41 +0000)
committerKeri Harris <keri@gentoo.org>
Sat, 17 Jun 2006 09:41:26 +0000 (09:41 +0000)
Package-Manager: portage-2.1

dev-lang/mercury-extras/ChangeLog
dev-lang/mercury-extras/files/digest-mercury-extras-0.13.0_beta20060615 [new file with mode: 0644]
dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild
dev-lang/mercury-extras/mercury-extras-0.13.0_beta20060615.ebuild [new file with mode: 0644]

index ed922478b4e83dba6bc64d6416d722da5534f458..ad11d61352b886320b9da5e236aa80a8c70990d0 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-lang/mercury-extras
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.32 2006/06/12 07:57:32 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.33 2006/06/17 09:41:26 keri Exp $
+
+*mercury-extras-0.13.0_beta20060615 (17 Jun 2006)
+
+  17 Jun 2006; Keri Harris <keri@gentoo.org>
+  -mercury-extras-0.13.0_beta20060609.ebuild,
+  +mercury-extras-0.13.0_beta20060615.ebuild:
+  New development snapshot.
 
 *mercury-extras-0.13.0_beta20060609 (12 Jun 2006)
 
diff --git a/dev-lang/mercury-extras/files/digest-mercury-extras-0.13.0_beta20060615 b/dev-lang/mercury-extras/files/digest-mercury-extras-0.13.0_beta20060615
new file mode 100644 (file)
index 0000000..09ce47c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c282460fa5c40e9f96d69a6cc6a1e80b mercury-extras-0.13.0-beta-2006-06-15-unstable.tar.gz 873669
+RMD160 4c753a8abd96eedad08bf0076a42214d34dd6d7e mercury-extras-0.13.0-beta-2006-06-15-unstable.tar.gz 873669
+SHA256 f3a57950a7f29c1a66e356058860cc9b882aa482191071bf659b92272d7a29f6 mercury-extras-0.13.0-beta-2006-06-15-unstable.tar.gz 873669
index 1567ded3df66f2433406da1893f36b55b9ecab5b..62dc1b67f0627b6383559ff453681a1913be9e41 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild,v 1.7 2006/06/08 18:52:38 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild,v 1.8 2006/06/17 09:41:26 keri Exp $
 
 inherit eutils
 
@@ -14,7 +14,7 @@ KEYWORDS="~ppc ~x86"
 
 IUSE="doc glut iodbc opengl tcltk"
 
-DEPEND="=dev-lang/mercury-0.12.2*
+DEPEND="~dev-lang/mercury-0.12.2
        sys-libs/ncurses
        glut? ( virtual/glut )
        iodbc? ( dev-db/libiodbc )
diff --git a/dev-lang/mercury-extras/mercury-extras-0.13.0_beta20060615.ebuild b/dev-lang/mercury-extras/mercury-extras-0.13.0_beta20060615.ebuild
new file mode 100644 (file)
index 0000000..26abdf2
--- /dev/null
@@ -0,0 +1,124 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.13.0_beta20060615.ebuild,v 1.1 2006/06/17 09:41:26 keri Exp $
+
+inherit eutils versionator
+
+BETA_V=$(get_version_component_range 4 $PV)
+BETA_V_YYYY=${BETA_V:4:4}
+BETA_V_MM=${BETA_V:8:2}
+BETA_V_DD=${BETA_V:10:2}
+MY_PV=$(get_version_component_range 1-3 $PV)-beta-${BETA_V_YYYY}-${BETA_V_MM}-${BETA_V_DD}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Additional libraries and tools that are not part of the Mercury standard library"
+HOMEPAGE="http://www.cs.mu.oz.au/research/mercury/index.html"
+SRC_URI="ftp://ftp.mercury.cs.mu.oz.au/pub/mercury/beta-releases/0.13.0-beta/${MY_P}-unstable.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE="doc glut iodbc odbc opengl tcltk"
+
+DEPEND="~dev-lang/mercury-${PV}
+       sys-libs/ncurses
+       glut? ( virtual/glut )
+       odbc? ( dev-db/unixODBC )
+       iodbc? ( !odbc? ( dev-db/libiodbc ) )
+       opengl? ( virtual/opengl )
+       tcltk? ( =dev-lang/tk-8.4*
+               || ( (
+                       x11-libs/libX11
+                       x11-libs/libXmu )
+               virtual/x11 ) )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-concurrency-r1.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-dynamic_linking.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-lex.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-mercury_glut.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-mercury_tcltk.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-mercury_opengl.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-odbc-r1.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-posix.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-references.patch
+       epatch "${FILESDIR}"/${P/${BETA_V}/beta}-trailed_update-r1.patch
+
+       sed -i  -e "s:curs:concurrency curs:" \
+               -e "s:posix:posix quickcheck:" \
+               -e "s:windows_installer_generator ::" Mmakefile
+       sed -i  -e "s:lib/mercury:lib/mercury-${PV}:" posix/Mmakefile
+
+       if built_with_use dev-lang/mercury minimal; then
+               sed -i -e "s:references::" Mmakefile
+       else
+               sed -i -e "s:xml:trailed_update xml:" Mmakefile
+       fi
+
+       use glut && sed -i -e "s: lex : graphics/mercury_glut lex :" Mmakefile
+       use tcltk && sed -i -e "s: lex : graphics/mercury_tcltk lex :" Mmakefile
+       use opengl && sed -i -e "s: lex : graphics/mercury_opengl lex :" Mmakefile
+
+       if use odbc ; then
+               sed -i -e "s:moose:moose odbc:" Mmakefile
+       elif use iodbc ; then
+               sed -i -e "s:moose:moose odbc:" Mmakefile
+               sed -i -e "s:MODBC_DRIVER=MODBC_UNIX:MODBC_DRIVER=MODBC_IODBC:" odbc/Mmakefile
+       fi
+}
+
+src_compile() {
+       mmake depend || die "mmake depend failed"
+       mmake || die "mmake failed"
+
+       if use opengl && use tcltk ; then
+               cd "${S}"/graphics/mercury_opengl
+               cp ../mercury_tcltk/mtcltk.m ./
+               mmake -f Mmakefile.mtogl depend || die "mmake depend mtogl failed"
+               mmake -f Mmakefile.mtogl || die "mmake mtogl failed"
+       fi
+}
+
+src_install() {
+       cd "${S}"
+       mmake INSTALL_PREFIX="${D}"/usr install || die "mmake install failed"
+
+       if use opengl && use tcltk ; then
+               cd "${S}"/graphics/mercury_opengl
+               mv Mmakefile Mmakefile.opengl
+               mv Mmakefile.mtogl Mmakefile
+               mmake INSTALL_PREFIX="${D}"/usr \
+                       install || die "mmake install mtogl failed"
+       fi
+
+       cd "${S}"
+       if use doc ; then
+               docinto samples/complex_numbers
+               dodoc complex_numbers/samples/*.m
+
+               docinto samples/curs
+               dodoc curs/samples/*.m
+
+               docinto samples/curses
+               dodoc curses/sample/*.m
+
+               docinto samples/dynamic_linking
+               dodoc dynamic_linking/hello.m
+
+               docinto samples/lex
+               dodoc lex/samples/*.m
+
+               docinto samples/moose
+               dodoc moose/samples/*.m moose/samples/*.moo
+
+               docinto samples/references
+               dodoc references/samples/*.m
+       fi
+
+       dodoc README
+}