projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
380b5cd
)
dev-python/beaker:
author
Ian Delaney
<idella4@gentoo.org>
Sat, 15 Aug 2015 12:22:40 +0000
(20:22 +0800)
committer
Ian Delaney
<idella4@gentoo.org>
Sat, 15 Aug 2015 12:22:40 +0000
(20:22 +0800)
Tidy to test phase, notate issue filed upstream in test phase re
apparent regression in one test file wrt bug #557026"
Package-Manager: portage-2.2.20
dev-python/beaker/beaker-1.7.0-r1.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/beaker/beaker-1.7.0-r1.ebuild
b/dev-python/beaker/beaker-1.7.0-r1.ebuild
index b54d0ce92643b824e3b57d64176d6083e663c517..13b2fe6c5a2107622879809d465e5925c3dd62e1 100644
(file)
--- a/
dev-python/beaker/beaker-1.7.0-r1.ebuild
+++ b/
dev-python/beaker/beaker-1.7.0-r1.ebuild
@@
-38,10
+38,9
@@
python_prepare_all() {
}
python_test() {
+ # https://github.com/bbangert/beaker/issues/86; bug #557026
cp -r -l tests "${BUILD_DIR}"/ || die
- pushd "${BUILD_DIR}"/tests > /dev/null
- nosetests || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
}
pkg_postinst() {